1

I am running Plesk on Debian Since i installed Plesk almost 6 months ago every time i restarted the server nginx would fail to start on boot and i would have to go and manually restart it. Now today i needed to restart the server again but this time i can't even manually restart nginx.

I get this:

Starting nginx (via systemctl): nginx.serviceJob for nginx.service failed.
See 'systemctl status nginx.service' and 'journalctl -xn' for details.
failed!

systemctl status nginx.service returns:

● nginx.service - Startup script for nginx service
Loaded: loaded (/lib/systemd/system/nginx.service; enabled)
Active: failed (Result: exit-code) since Wed 2016-03-09 23:00:15 MST; 25min ago
Process: 4723 ExecStartPre=/usr/sbin/nginx -t (code=exited, status=1/FAILURE)
Process: 4720 ExecStartPre=/usr/bin/test $NGINX_ENABLED = yes (code=exited, status=0/SUCCESS)
Mar 09 23:00:15 fineartschool.net nginx[4723]: nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
Mar 09 23:00:15 fineartschool.net nginx[4723]: nginx: [emerg] bind() to 64.4.6.100:80 failed (99: Cannot assign requested address)
Mar 09 23:00:15 fineartschool.net nginx[4723]: nginx: configuration file /etc/nginx/nginx.conf test failed
Mar 09 23:00:15 fineartschool.net systemd[1]: nginx.service: control process exited, code=exited status=1
Mar 09 23:00:15 fineartschool.net systemd[1]: Failed to start Startup script for nginx service.
Mar 09 23:00:15 fineartschool.net systemd[1]: Unit nginx.service entered failed state.

And journal -xn reads

-- Logs begin at Wed 2016-03-09 22:49:30 MST, end at Wed 2016-03-09 23:10:01 MST. --
Mar 09 23:05:01 fineartschool.net CRON[6067]: pam_unix(cron:session): session closed for user root
Mar 09 23:09:01 fineartschool.net CRON[7188]: pam_unix(cron:session): session opened for user root by (uid=0)
Mar 09 23:09:01 fineartschool.net CRON[7189]: (root) CMD (  [ -x /usr/lib/php5/sessionclean ] && /usr/lib/php5/sessionclean)
Mar 09 23:09:01 fineartschool.net CRON[7188]: pam_unix(cron:session): session closed for user root
Mar 09 23:09:47 fineartschool.net CRON[4606]: pam_unix(cron:session): session closed for user root
Mar 09 23:10:01 fineartschool.net CRON[7505]: pam_unix(cron:session): session opened for user root by (uid=0)
Mar 09 23:10:01 fineartschool.net CRON[7506]: pam_unix(cron:session): session opened for user root by (uid=0)
Mar 09 23:10:01 fineartschool.net CRON[7507]: (root) CMD (/opt/psa/admin/bin/php -dauto_prepend_file=sdk.php '/opt/psa/admin/plib/modules/magicspam/script|
Mar 09 23:10:01 fineartschool.net CRON[7508]: (root) CMD (/opt/psa/admin/bin/php -dauto_prepend_file=sdk.php '/opt/psa/admin/plib/modules/plesk-mobile/scr
Mar 09 23:10:01 fineartschool.net CRON[7505]: pam_unix(cron:session): session closed for user root

and the nginx error log

2016/03/09 22:28:57 [emerg] 952#0: bind() to 64.4.6.100:80 failed (99: Cannot assign requested address)
2016/03/09 22:31:14 [emerg] 2675#0: bind() to 64.4.6.100:80 failed (99: Cannot assign requested address)
2016/03/09 22:34:56 [emerg] 914#0: bind() to 64.4.6.100:80 failed (99: Cannot assign requested address)
2016/03/09 22:38:36 [emerg] 2670#0: bind() to 64.4.6.100:80 failed (99: Cannot assign requested address)
2016/03/09 22:39:26 [emerg] 941#0: bind() to 64.4.6.100:80 failed (99: Cannot assign requested address)
2016/03/09 22:42:17 [emerg] 2795#0: bind() to 64.4.6.100:80 failed (99: Cannot assign requested address)
2016/03/09 22:42:32 [emerg] 2912#0: bind() to 64.4.6.100:80 failed (99: Cannot assign requested address)
2016/03/09 22:46:17 [emerg] 4026#0: bind() to 64.4.6.100:80 failed (99: Cannot assign requested address)
2016/03/09 22:46:26 [emerg] 4092#0: bind() to 64.4.6.100:80 failed (99: Cannot assign requested address)
2016/03/09 22:49:49 [emerg] 795#0: bind() to 64.4.6.100:80 failed (99: Cannot assign requested address)
2016/03/09 22:52:31 [emerg] 2517#0: bind() to 64.4.6.100:80 failed (99: Cannot assign requested address)
2016/03/09 23:00:15 [emerg] 4723#0: bind() to 64.4.6.100:80 failed (99: Cannot assign requested address)

Any help would be greatly appreciated!

Thanks in advance!

0

Well this is embarrassing. So the after looking at the recurring pattern "(99: Cannot assign requested address)" I decided to look at the servers assigned IP Address and it turns out it didn't pick up it's static IP Address instead picked up a dynamic IP Address.

After correcting this i was able to restart nginx. Hopefully someone else will be able to benefit from this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.