1

On RHEL 7.x I observe that the remote filesystems (SAN) does not allow host to come up after reboot. It enters maintenance mode and I've to comment out the entries in /etc/fstab to bring the host up and running.

I've few mount points /etc/fstab created over LVM stack which in turn is laid on iSCSI LUNs.

I guess this is due to systemd introduced from RHEL 7.x onwards. However I'm unable to get remote filesystems mounted after local filesystems. Let me know how/where to specify this ordering?

2

Got this working by having _netdev as one of the mount options. Also setting use_lvmetad in /etc/lvm/lvm.conf to 1 will bring the VGs/LVs online and mounts work without any issues. I do not observe the host going into maintenance mode after reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.