1

To connect multiple tunnel endpoints to a common bridge interface, I have to create a Layer 2 tunnel over ssh. The server is Ubuntu 10.04, the client is Ubuntu 14.04. I have enabled

PermitTunnel yes
PermitRootLogin yes

in the servers /etc/sshd_config. When I'm connecting with sudo ssh -w any:any -o "Tunnel=ethernet" root@remote I get a tun device instead of the expected tap device. If I change "PermitTunnel yes" to "PermitTunnel ethernet" on the server, I get a "channel 0: open failed: administratively prohibited: open failed" error message and no tunnel device at all.

I'm at a loss, because I'm positive that this used to work at some point in the past (with different machines and probably Linux versions).

  • what openssh version do you have on the ubuntu 10? I would guess it will be pretty old (EOL?) and it might miss some features. – Jakuje Mar 9 '16 at 16:19
  • The sshd version on Ubuntu 10 should not be the problem. The man page documents the PermitTunnel option with both point-to-point and ethernet as valid values. Anyway, the version is 1:5.3p1. – jpo234 Mar 9 '16 at 16:35
  • That's a bit old Ubuntu you are running. Did you try connecting with a more recent version? With a live-cd maybe? – We are Borg Mar 9 '16 at 16:36
  • I'm not sure I understand your question correctly, but as I wrote in my question: the server is Ubuntu 10.04 (pretty old, I admit) and the client is Ubuntu 14.04LTS. – jpo234 Mar 9 '16 at 16:39
1

I have the same problem. According to my tests, it is not related to the server, instead it has something to do with the client. Either ssh build and configuration, either due to the local network configuration.

I've been able to create a tap interface between my laptop and all of my devices but when I tried to tunnel between the devices, only tun interfaces were created.

[edit] The workaround consists in putting the "-o" before the "-w" like this :

ssh -o Tunnel=ethernet -w any:any root@remote

instead of :

ssh -w any:any -o Tunnel=ethernet root@remote

I tried it myself, it works, here is the source : https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1316017

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.