0

My target is to increase the ring buffer ( I have Linux red-hat 7.1 ) , but I get the following:

ethtool -G eth1 rx 8192
Cannot set device ring parameters: Invalid argument

so how to enable this value? , or maybe this is the MAX value?

the current status:

ethtool -g eth1
Ring parameters for eth0:
Pre-set maximums:
RX:             4096
RX Mini:        0
RX Jumbo:       0
TX:             4096
Current hardware settings:
RX:             256
RX Mini:        0
RX Jumbo:       0
TX:             512

I want to increase the ring buffer because errors - pkts rx OOB - indicate that the network card is out of buffer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.