1

SCP is working, but the sshfs is displaying the above error.

sudo sshfs -o allow_other -o transform_symlinks username@192.168.2.207:/ /media/SSHFS_bbb
2
  • You are saying sudo scp username@192.168.2.207:/etc/profile /tmp works, while the sshfs command above doesn't? Mar 9, 2016 at 5:53
  • 1
    Hi @tharunkumar, welcome to Unix & Linux. Please do not post a question and answer in the same place. If you have found the answer, answer to yourself in the answer box. Mar 9, 2016 at 8:06

3 Answers 3

2

Found the solution - host key is changed, Need to update it.

update the Host key of the IP address

sudo ssh-keygen -f "/root/.ssh/known_hosts" -R 192.168.2.207

After this sshfs is working, I am able to mount the complete file system.

0

In my case, I have done:
-o ssh_command='sshpass -p xxx ssh'
password is right, and get "Connection reset by peer", after remove the option, succeed.

0

in my case, it was the ControlPath ssh-config value which couldn't handle the connectionURI (in my case a stack-url containing @).
I changed my ControlPath in ~/.ssh/config to:

ControlPath ~/.ssh/sockets/%C

and then it worked

ps. make sure the sockets-dir exists (run mkdir ~/.ssh/sockets e.g.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.