0

Initially my boot time was really low, it used to boot in seconds and user processes were also up and ready to use within a minute, now for some reason my boot up really slow and also my system never shuts down, every single time l'll have to manually press the power button to turn off the machine ( stuck at ubantu load page while shutdown, sometimes whole screens pixels act weird and output different colors) I ran some commands to check if there was an issue here, so I found in dmesg there is jump from 50 to 2358 seconds, here is my full dmesg report

snippet:

[   32.924217] /dev/vmnet: open called by PID 1417 (vmnet-natd)
[   32.924225] /dev/vmnet: hub 8 does not exist, allocating memory.
[   32.924237] /dev/vmnet: port on hub 8 successfully opened
[   32.958592] userif-3: sent link down event.
[   32.958595] userif-3: sent link up event.
[   32.986723] /dev/vmnet: open called by PID 1418 (vmnet-netifup)
[   32.986732] /dev/vmnet: port on hub 8 successfully opened
[   33.295624] /dev/vmnet: open called by PID 1431 (vmnet-dhcpd) 
[   33.295646] /dev/vmnet: port on hub 8 successfully opened
[   39.559495] dell_laptop: Keyboard brightness level control not      
supported
[   39.821671] dell_laptop: Keyboard brightness level control not 
supported
[   50.011334] /dev/vmmon[0]: HostIFReadUptimeWork: detected 
settimeofday: fixed uptimeBase old 18445286791255852801 new   
18445286791266192862 attempts 1
[ 2358.980587] bridge-wlp7s0: disabling the bridge
[ 2358.984674] cfg80211: World regulatory domain updated:
[ 2358.984680] cfg80211:  DFS Master region: unset
[ 2358.984682] cfg80211:   (start_freq - end_freq @ bandwidth),   
(max_antenna_gain, max_eirp), (dfs_cac_time)
[ 2358.984701] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 
2000 mBm), (N/A)
[ 2358.984704] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 
2000 mBm), (N/A)
[ 2358.984707] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 
2000 mBm), (N/A)
[ 2358.984710] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 
KHz AUTO), (N/A, 2000 mBm), (N/A)

where wlp7s0 is my wifi network interface,I dont know if this is the actual problem but this is my hunch. and my GRUB file at /etc/default/grub is

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=pci"
GRUB_CMDLINE_LINUX=""

I dont think anything here is causing the shutdown problem, still not able to figure it out !!

My CPU Stats:

lscpu 
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    2
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 58
Model name:            Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
Stepping:              9
CPU MHz:               1208.203
CPU max MHz:           3100.0000
CPU min MHz:           1200.0000
BogoMIPS:              4988.81
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              3072K
NUMA node0 CPU(s):     0-3
free -h
             total       used       free     shared    buffers     cached
Mem:          5.7G       5.6G       158M       3.0G       167M       3.7G
-/+ buffers/cache:       1.7G       4.0G
Swap:         5.9G       125M       5.8G
lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.10
Release:    15.10
Codename:   wily

Please help me fix these issues. in short: need fast boot up and actually shut down rather than me manually pressing the button to turn it off. here is how my screen looks after 5-10 seconds after me pressing shutdown button,my guess is display driver has an issue, how to fix it? my screen (note: I have reviewed start-up applications and none of it seems heavy)

1

As indicated in the dmesg report, there appears to be a problem somewhere with /dev/vmmon which is an interface of the VMware kernel driver used for example by VMware Workstation. It seems to attempt to set the system time during boot, and such operations can cause freezes as the system adjusts to it.

I'd suggest attempting to blacklist or uninstall the vmware modules if you don't use them to correct the problem, at least temporarily for troubleshooting

  • Surprisingly this seemed to work, but haven't yet fixed my weird looking shutdown screen, any help on that ? – hubatrix Mar 10 '16 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.