1

I'm using Debian Jessie with Mate desktop.

I installed samba and added my user to sambashare group. I can write in /var/lib/samba/usershares/.

Yet, I can't share a folder using the "share folder" action in the contextual menu of the file manager without being asked for root password.

Anything I'm missing ?

In a former Debian install, I'm pretty sure I could add/modify a share without root password.

Also, I can only share with everyone, either read-write or read-only. I think I used to be asked whether I wanted to share with everyone or only my user, for instance.

What is the recommender way to configure / use samba user shares using the GUI in Mate?

2

It appears I didn't have caja-share installed. I installed it and now I have both Sharing Options and Share Folder entries in the context menu.

Using Share Folder still behaves as described in the question, but Sharing Options does what I want: I can share without root password, and share with everyone in both RO and RW.

It seems both entries don't act at the same level. The first (the one that needs root privileges) modifies /etc/samba/smb.conf. I wouldn't mind getting rid of the now useless and confusing Share Folder menu entry, but this is just a detail.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.