1

I own a Xerox Phaser 3020 printer wich I want to use from a computer running on Debian 8, Jessie. The drivers available at Xerox's web site support Debian 5.0 - 7.1. So they explicitly state that there is no Debian 8 support.

I've tried installing the drivers anyway. Not surprisingly they don't work regardless of the way I connect to the printer (USB or LAN). Is there a way I can bypass this restriction and make the drivers that work on Debian7.1 work on Debian8?

Alternatively I can access via IP the printer's Centreware Internet Services page. There I can load a 'print-ready file' (extension .prn) for the printer to print. How can I generate this file without the drivers installed?

  • Given that this printer is a "PostScript Printer" there should be no problem. In fact, the drivers recomended here are almost generic and is only a PPD file for CUPS. Just follow the steps given in the above link. ...... Or: ... Are you trying to get the printer working with some other server different from CUPS? – user79743 Mar 4 '16 at 20:39
  • CUPS alone didn't come with the drivers or could't find them. That's why I tried to install the drivers manually. I just solved it. The drivers were correctly installed, but I had to re-add the printer in CUPS, then it found the installed drivers and it worked perfectly. It missed that obvious step. – sebalander Mar 5 '16 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.