2

I am trying to move a Debian squeeze installation to VMWare VSphere 5.5 environment. However when booting the new machine after replication, the initrd/busybox gives an error, that it cannot mount the root-partition (invalid argument). However the driver for sda was loaded successfully and correctly detected all partitions previously (see screenshot below).

Following things have been done:

  • New/Blank VMWare-machine has been booted with GRML, Partitions created and data rsynced from the remote host
  • DiskIDs replaced with /dev/sda in udev/fstab/grub, initramfs updated
  • Grub bootloader installed

Upon reboot grub loads correctly, linux-image and initrd are correctly loaded and executed.

  • The kernel indicates, that it has found sda and partitions (sda1,sda2,...)
  • Init error message: mount failed, invalid argument
  • In busybox mount /dev/sda1 /mnt also fails with "invalid argument"
  • cat /dev/sda1 gives data, so hdd partition can be accessed
  • dmesg does not indicate any error when trying to mount

I also tried following things:

  • manually loading xfs and ext2 drivers before mount
  • using the VMware converter (same result)

Screenshot after failed boot: mount_failed

Does anyone has some clues or ideas?

0

2 Answers 2

1

The BusyBox version number has a ”+deb6u11” suffix. That suggests Debian version 6, or “squeeze”. That’s rather old.

Perhaps GRML and VMWare Converter are creating a XFS filesystem (or other filesystem type) that includes some newer features that cannot be handled by the Squeeze kernel?

2
  • 1
    Problem solved some time ago: But your answer is correct, you have to format with an xfs programm version which corresponds to your kernel. XFS-partions formated with a newer kernel are not recognized by some older kernels. Apr 24, 2018 at 9:44
  • Thanks for sharing this. Can confirm that using the fs tooling matching the kernel is important. I had the issue when converting a node from physical to virtual, the livecd fs tools were for a modern kernel, and the older kernel was throwing "Invalid filesystem option set:" error during boot. Solved by using the fs tools from the source physical node, which matched the source physical kernel.
    – Kyle
    Oct 13, 2019 at 15:11
0

Try mount -t ext4 /dev/sda1 /mnt (replace ext4 with whatever you formatted the partition to). This helped me in a similar situation.

1
  • mount returns "invalid argument", also for all other partitions and fs types (which mount mounts without problems under grml). But /dev/sda1 exists and can be accessed. Mar 6, 2016 at 15:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .