4

Let's say I have,

On screen 1:

  • workspace A: a web browser, extended (not full-screened with F11, just maxed out).
  • workspace B: a terminal with Vi for example.

On screen 2:

  • a web browser, full-screened.

When I switch, with Ctrl+Alt+or, from workspace A to workspace B on screen 1, my cursor switch to screen 2 if, and only if, I have something full-screened.

I lose my cursor focus and it's annoying when I'm editing a file with Vi, while watching a video in full screen on my second screen, check something on chrome and go back to my Vi instance as what I type is now typed on my chrome instance on my other screen.

Is it possible to force my cursor to stay on my first screen when I have a full-screened window in my second screen?

I'm on Debian Jessie and Gnome 3.

  • I think this feature would have supported to the window manager (otherwise there's likely to be a visible delay between switching workspaces and moving the cursor). Which window manager are you using? Are you prepared to change? Gnome typically favors a lack of flexibility, and for example I doubt that Metacity has anything close to what you want, but there are window managers that you can use with Gnome where you can add this feature with a few lines of code in your configuration file, e.g. Sawfish. – Gilles Mar 4 '16 at 21:12
0

This isn't too much of a fix as it is an annoyance minimizer, but in System->Preferences->Monitors, drag the 2nd monitor to the edge so that they only touch corners. Theoretically, that means it'll only transfer over if you pull the mouse into a corner. On the Debian/Gentoo Wiki, they posted a small program that might work also. Good luck my man

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.