1

I'm using Kitty (putty clone) and Keepass agent (similar to pagent). Keepass agent contains 5 ssh keys.

This setup works fine with all linux boxes I've encountered so far, connection to our new RHEL7 linux box fails with

type 2 (protocol error): "Too many authentication failures for ..."

I added

MaxAuthTries 6

to /etc/ssh/sshd_config and did a

systemctl restart sshd.service

but the error remains.

0

Logging in Kitty in revealed that after the 5 ssh keys an extra GSSAPI authentication attempt was made

Event Log: Using SSPI from SECUR32.DLL
Event Log: Attempting GSSAPI authentication

this caused the 6th attempt too fail.

Setting

MaxAuthTries 10

solved this.

As Jakuje pointed out increasing MaxAuthTries is not the best approach so I reverted that change and went back to the Kitty config to disable the unused GSSAPI authentication .

Connection -> ssh -> auth -> GSSAPI : uncheck "Attempt GSSAPI authentication"

This solved the issue without lowering the security

  • 2
    rather turn off the failing authentication methods than bumping the amount. This is not much future proof nor secure. – Jakuje Mar 4 '16 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.