I'm running a dual boot Windows/Mint partition. Everything is going fine until things suddenly get REALLY screwy and slow. I get a popup that "Filesystem root only has 297.8 MB disk space remaining."

I ran df -k and got this output:

Filesystem        1K-blocks     Used Available Use% Mounted on
/dev/sda5          19091584 17807900    290816  99% /
none                      4        0         4   0% /sys/fs/cgroup
udev                4038960        4   4038956   1% /dev
tmpfs                811000     1704    809296   1% /run
none                   5120        0      5120   0% /run/lock
none                4054984    15288   4039696   1% /run/shm
none                 102400       12    102388   1% /run/user
/dev/sda6          57433348  8825192  45667588  17% /home
/dev/sda2             97280    23312     73968  24% /boot/efi
/home/jd/.Private  57433348  8825192  45667588  17% /home/jd
/dev/sdb1         976760404  1861952 974898452   1% /media/jd/TOSHIBA EXT

This is what my du -hs /* looks like when run from /:

9.8M    /bin
72M /boot
4.0K    /cdrom
4.0K    /dev
27M /etc
17G /home
0   /initrd.img
327M    /lib
4.0K    /lib64
16K /lost+found
1.6G    /media
4.0K    /mnt
374M    /opt
du: cannot access ‘/proc/3134/task/3134/fd/4’: No such file or directory
du: cannot access ‘/proc/3134/task/3134/fdinfo/4’: No such file or directory
du: cannot access ‘/proc/3134/fd/4’: No such file or directory
du: cannot access ‘/proc/3134/fdinfo/4’: No such file or directory
0   /proc
5.4M    /root
du: cannot access ‘/run/user/1000/gvfs’: Permission denied
2.4M    /run
16M /sbin
4.0K    /srv
0   /sys
64K /tmp
5.0G    /usr
12G /var
0   /vmlinuz

I'm pretty lost on how to go about resizing the partitions or how that partition even filled up so fast. Deleting large files from my Home folder doesn't seem to do anything, as there's still a lot of space in there.

  • 2
    most of you space on / is in /usr and /var. /var/ usually has old log files that are zipped. clean up these. software that was installed later may go into /usr/ - you could deinstall some of these if not essential. – jai_s Mar 4 '16 at 6:26
  • Please use df -hT and du -ks * | sort -nr | cut -f2 | xargs -d '\n' du -sh for better readability and edit the question accordingly. – Keyshov Borate Mar 4 '16 at 6:46

I have solved the issue. My /var/log directory contained a logfile and kern.log that were each over 5.7GB each. It seems that my machine was logging the same lengthy error thousands of times over, which quickly filled my machine.

  • 3
    The next thing you need to do is find out what was causing those errors and fix it - otherwise your / filesystem is just going to fill up again. Also, allocating only 20GB to / was probably a mistake as that's where the operating system and all system packages, log files, /var/cache, and lots of other stuff lives.,,,you probably would have been better off having just one big / fs rather than / and /home. – cas Mar 4 '16 at 7:35
  • 20GB in / isn't necessarily a mistake, and splitting out /home is very common. – EightBitTony Mar 4 '16 at 10:54
  • Is there no log-rotation service here? – Otheus Mar 4 '16 at 17:24
  • To bandaid the issue, do something like grep -vF "repeating logline text" /var/log/kern.log >/home/kern.log && mv /home/kern.log /var/log/ followed by rsyslog restart. normally you would use sed -i but you might not have enough space. Next, on Mint, you can create a file in /etc/rsyslog.d/ to bandaid the logging problem by telling it to exclude that line from the logs. The file will be named 00_exclude and have the line :msg, contains, "repeating logline text". See rsyslog.com/doc/v8-stable/configuration/filters.html – Otheus Mar 4 '16 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.