5

I have an X1 Yoga with a 14'' WQHD and I want to rotate the screen to use it with the stylus but xrandr fails to rotate.

xrandr --output eDP1 --rotate <orientation>

works for normal and inverted, but returns the following error for left and right :

xrandr: Configure crtc 0 failed

Idem for

xrandr -o <number>

it works properly for 0 and 2 but returns the error :

Failed to change the screen configuration!

for the values 1 and 3. If re-run xrandr -o 1 a second time it crash with a blank screen.

update My graphics unit is Intel® HD Graphics 520 (Skylake GT2). As driver I installed the package xserver-xorg-video-intel

2
  • That means your graphics driver is incomplete and buggy. What exact model of graphics card is it? If it's an Nvidia or ATI chip, which driver are you using (proprietary or free)? Mar 3, 2016 at 23:30
  • HD Graphics 520 and the package xserver-xorg-video-intel is installed. Mar 4, 2016 at 17:54

3 Answers 3

5

After I upgrade Xorg to X.Org X Server 1.19.5, it solved that issue. to get the version of Xorg

Xorg -version

and to upgrade Xorg on ubuntu 16.04

sudo apt install xserver-xorg-hwe-16.04
4
  • This is the right answer for me. I don't have the configuration /usr/share/X11/xorg.conf.d/20-intel.conf, so the accepted answer doesn't apply to my case. Installing xserver-xorg-hwe-16.04 does the trick for me. May 14, 2018 at 0:10
  • Same on 16.04 on Intel graphics. Initially second monitor would not display after rotation, installing this solved the issue. More info about HWE here: wiki.ubuntu.com/Kernel/LTSEnablementStack
    – Bar
    Jun 26, 2018 at 17:51
  • Worked for me after a whole day of troubleshooting. Sep 12, 2019 at 0:45
  • Worked perfectly after running this and a reboot. Also got this error from the Settings GUI (which I haven't been able to find anywhere, but in case someone else sees this): could not set the configuration for crtc 63
    – mz496
    Mar 20, 2020 at 17:14
1

Removing the configuration file /usr/share/X11/xorg.conf.d/20-intel.conf solved the problem.

0

I have exactly the same problem but without the file /usr/share/X11/xorg.conf.d/20-intel.conf . I find it is caused by the kernel 4.13.0-16. When I switch to the kernel 4.10.0-38, xrandr works perfectly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .