0

This question is not just depended on Zorin OS distribution.

I can't use the wireless internet. When I opened the program called 'Device Manager' on Windows, my network adapter was 'Broadcom 802.11 Network Adapter', and there was 'Realtek PCIe GBE Family Controller' too. (My computer is HP Probook 470)

I tried other Debian-based distros, but I failed.

I can't find the wireless internet. Ethernet works. But my room's structure is not good for connecting to the Ethernet.

What should I try?

Update:

09:00.0 Network Controller [0280]: Broadcom Corporation BCM43228 802.11a/b/g/n [14e4:4359]
  • 2
    Type : lspci -vnn | grep Network and give the output – GAD3R Mar 3 '16 at 14:09
  • @GAD3R I added to the question. – User Mar 4 '16 at 10:25
  • Have you considered buying a longer ethernet cable (and hiding it behind furniture etc wherever possible)? Don't forget to use duct tape or similar if the cable needs to cross a doorway or other high-traffic area. – cas Mar 12 '16 at 3:40
0

You need to install bcmwl-kernel-source Type the following command:

sudo apt-get update
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

If you have an error, Try to install linux-headers and build essential:

sudo apt-get install build-essential linux-headers-generic

FEDORA

Install the RPM Fusion repositories. rpmfusion

Determine the architecture of the running kernel.

uname -r

Do this step only if you need to install the kmod version of the driver for the i686 or x86_64 kernels.

 su
 yum install kmod-wl

Do this step only if you need to install the kmod version of the driver for the PAE kernel.

 su
 yum install kmod-wl-PAE

Do this step only if you want to install the akmod version of the driver for any kernel.

su
yum install akmod-wl

Now reboot or restart NetworkManager and look in the NetworkManager panel icon for available networks (left-click the icon)

Some things to try if it doesn't work

Check the installed packages against the running kernel. It should all make sense by the version numbers. If it doesn't, then fix the installed packages situation. And make sure the correct kernel is running for the installed kmod package versions

uname -r
rpm -qa | grep -e kernel -e broadcom-wl -e kmod-wl | sort

Check the loaded kernel modules. The wl module should be loaded, and potentially conflicting modules such as b43, b43legacy, and ssb should not be loaded.

lsmod | sort

If wl is not loaded, then try manually loading it.

 su
 modprobe wl
 service NetworkManager restart

If manually loading the module worked, then add that modprobe command to /etc/rc.local.

su
echo "modprobe wl" >> /etc/rc.local

If a conflicting module is being loaded, then blacklist the unwanted module. Examples:

su
echo "blacklist b43" >> /etc/modprobe.d/blacklist.conf
echo "blacklist ssb" >> /etc/modprobe.d/blacklist.conf

I get the Answer from fedoraforum.org

  • Thank you so much. What was the problem? What is bcmwl-kernel-source? – User Mar 5 '16 at 6:04
  • bcmwl = Broadcom 802.11 Linux STA wireless driver source – GAD3R Mar 5 '16 at 10:21
  • How can I install this on Fedora? – User Mar 6 '16 at 5:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.