1

I want to hear something immediately before the grub screen appears. I changed the following line in /etc/default/grub:

#GRUB_INIT_TUNE="480 440 1" 

by just removing the "#", so it looks like:

GRUB_INIT_TUNE="480 440 1" 

I then ran sudo update-grub command from the terminal. However, when I reboot my computer, I do not hear anything.

I am using Ubuntu 14.04.4 LTS. My system is EFI. I have some results from the Boot-Info-Script:

============================= Boot Info Summary: ===============================

=> Grub2 (v1.99) is installed in the MBR of /dev/sda and looks at sector 977614848 of the same hard drive for core.img. core.img is at this location and looks in partition 135 for .

sda1: __________________________________________________________________________

File system:       vfat
Boot sector type:  FAT32
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  
Boot files:        /efi/Boot/bootx64.efi /efi/ubuntu/grubx64.efi 
                   /efi/ubuntu/MokManager.efi /efi/ubuntu/shimx64.efi

sda2: __________________________________________________________________________

File system:       ext4
Boot sector type:  -
Boot sector info: 
Operating System:  Ubuntu 14.04.4 LTS
Boot files:        /boot/grub/grub.cfg /etc/fstab

sda3: __________________________________________________________________________

File system:       swap
Boot sector type:  -
Boot sector info: 

======================================================================== Also, I ran the following command:

 "sudo grub-install /dev/sda"

I got the following result:

 "Installing for x86_64-efi platform.Installation finished. No error reported."

What is the problem here, anything that I missed?

  • I edited your question to make it clearer. Please double check that it still describes exactly what you did. – terdon Mar 3 '16 at 14:09
  • I am not 100% sure of how GRUB works with EFI systems. However, if you're sure it's installed in the MBR of /dev/sda, then sudo grub-install /dev/sda should work. Did you try it? – terdon Mar 3 '16 at 15:00
  • I tried the command and reboot, unfortunately i got same result. I checked sound settings too. – ertugrul Mar 3 '16 at 15:05
  • OK. In that case, please edit your question and include the exact command you ran and its output, if any. By the way, are you sure you're actually seeing grub and not the EFI bootloader? Also, I think Ubuntu hides the bootloader screen unless you have more than one OS installed. – terdon Mar 3 '16 at 15:06
  • Yes, when i open my computer, the grub screen appears.Yes I got only Ubuntu. Normally, it hides, but i installed grub on my own just for the purpose of understanding and changing grub settings. – ertugrul Mar 3 '16 at 15:16
3

Running sudo update-grub will generate a new config file for GRUB, but you still need to (re)install it onto your hard drive. On a non-EFI system, where GRUB is installed in the MBR of the first hard drive, you can do that with

sudo grub-install /dev/sda

If you're on an EFI system, or if your GRUB is installed elsewhere, you will need to updated your question and give us more information before we'll be able to help.

|improve this answer|||||
  • I updated my question, i hope it is fine for now. – ertugrul Mar 3 '16 at 14:52
2

What you may have missed is that:

GRUB_INIT_TUNE="480 440 1" uses the old school "beep speaker" attached to the 4 pin header on the motherboard as sound card drivers are not loaded at this point. If you don't have a speaker attached to that header you won't hear anything.

Source: Testing

|improve this answer|||||
  • Good point (though more of a comment than an answer, really). Do laptops not have that? I could have sworn I;ve heard mine beep at me in displeasure once or twice. That's an essential diagnostic tool when fiddling with hardware. Are you sure laptops don't tend to have it? – terdon Mar 3 '16 at 16:01
  • @terdon good point. I can't speak for all laptops but I'm fairly certain that I've hit on the source of the problem. As the question stands ATM. Also meta.unix.stackexchange.com/questions/3925/… – Elder Geek Mar 3 '16 at 16:07
  • I guess i tried as much as i can. Most probably, i do not have a "beep speaker". – ertugrul Mar 3 '16 at 19:22
  • In the old times of separate sound cards, the sound cards sometimes had an input to feed the BIOS sound output to the sound card. So if your PC had no internal speaker, you could use the sound card output instead. Maybe even the other way around: you could feed the sound card output to the internal speaker. Some current desktop PCs seem to have an internal speaker again that allows the BIOS to beep. Short answer: It's a hardware problem, most likely. – U. Windl Mar 21 '19 at 10:15
  • @u-windl I have yet to see a desktop board in the past 20 years that didn't have either one soldered on or at least a 4 pin header for one... – Elder Geek Mar 21 '19 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.