108

I’m running a Debian Squeeze web server. I’ve installed memcached on it, and configured memcached to listen on a Unix domain socket (at /tmp/memcached.sock), as it only needs to receive messages from the website, which lives on the same server.

It seems to be working fine, but I’d also like to communicate with memcached via the shell, to check that it’s doing what I think it’s doing.

memcached accepts messages via a simple ASCII protocol (if I understand correctly). If it was listening on TCP/IP, I could send messages to it via e.g. nc:

$ echo "stats settings" | nc localhost 11211

But I can’t figure out how to send that text to the domain socket instead.

On my laptop (which runs OS X Lion), both nc and telnet have options (-U and -u respectively) to use domain sockets. However, on my Debian Squeeze web server, these options aren’t present.

78

With netcat-openbsd, there is a -U option. If you don't have it, you probably have netcat-traditional installed instead; I'd suggest switching.

Example command: nc -U /var/run/socket

| improve this answer | |
  • so netcat will create a new file at /var/run/socket? Is there a way to reuse an existing file? – Alexander Mills Jun 4 '19 at 19:22
  • 1
    @AlexanderMills If you tell it to listen (-l), it'll create the file. Otherwise, it expects the socket to already exist (and already have something listening on it). So the example command in the answer does not create the file. – derobert Jun 5 '19 at 18:51
100

With socat (a 'bidirectional data relay between two data channels') you can connect to the unix domain socket like this:

$ socat - UNIX-CONNECT:/tmp/memcached.sock
| improve this answer | |
23

netcat-openbsd supports connecting to UNIX-domain sockets. Using this you can connect to either a UNIX-domain stream socket or a UNIX-domain datagram socket, and therefore you have to tell the socket's type to netcat.

for example, /dev/log file in Linux is a UNIX-domain datagram socket socket, thus nc -U /dev/log won't work. Instead use nc -uU /dev/log. Using -u along with -U tells netcat that it is a UNIX-domain datagram socket.

nc -U /tmp/socket  #Connect to UNIX-domain stream socket
nc -uU /tmp/socket #Connect to UNIX-domain datagram socket


Similarly, while using socat, use UNIX-CLIENT option. Using this option you can connect to both UNIX-domain stream and UNIX-domain datagram sockets. From its man page (man socat), "It first tries to connect and, if that fails, assumes it is a datagram socket, thus supporting both types".

socat - UNIX-CLIENT:/dev/socket #connect to UNIX-domain socket, irrespective of its type
| improve this answer | |
15

You can use socat on Debian. To install it:

# apt-get install socat
| improve this answer | |
3

If you happen to be on a system that only has busybox installed, it may look like it doesn't support unix domain sockets (the -U option doesn't exist) but I found the following works:

$ echo "stats slabs" | nc local:/tmp/memcached.sock
STAT active_slabs 0
STAT total_malloced 0
END

This can be really helpful for creating health checks for alpine containers.

| improve this answer | |
  • Could you add the required configuration options for this to work? Enabling CONFIG_FEATURE_UNIX_LOCAL is not sufficient. I also played with CONFIG_NC_EXTRA and CONFIG_NC_110_COMPAT but neither of that helped. – yman Apr 2 at 8:17
  • @yman I was just using a precompiled binary in an Alpine container. I think the config settings were git.alpinelinux.org/aports/tree/main/busybox/busyboxconfig or git.alpinelinux.org/aports/tree/main/busybox/… – Greg Bray Apr 2 at 8:23
  • Seems both NC_EXTRA and NC_110_COMPAT config options need to be enabled, of course together with CONFIG_FEATURE_UNIX_LOCAL. Please consider extending the answer. – yman Apr 2 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.