0

Yes I know - a floppy drive.

but.... I want to extract a whole bunch of samples of old floppy discs (about 300 discs) from my Ensoniq EPS sampler (that has died).

I am using a C program called Epslin to do this. This is working fine and I can extract the samples but the floppy drive can only be accessed as root, so everything I extract is owned by root so I have to go and 'chown' all the files. This is not a huge deal but painfull enough for me to do.

I am just not sure how to set the floppy drive so it can be accessed by me (normal user).

I have Googled this and done the following:

  • installed fdutils
  • in /lib/udev/rules..d/80-udisks2.rules - I have changed the references to floppy so they end in a 1 i.e. KERNEL=="fd*", ENV{ID_DRIVE_FLOPPY}=“1”
  • my user is part of the floppy group
  • in /etc/fstab I added - /dev/fd0 /floppy auto noauto,sync 0 0

When I try to just mount the floppy normally via terminal it says only root can mount

If I try to mount the floppy from the icon in the file explorer an error box says "failed to mount floppy disk" not authorised to perform operation

I am not sure what else I need to do?

This is on Debian 8

  • 1
    Try adding uid=501 (or whatever your numeric userid is) to the options field of the fstab entry to make all files appear to be owned by you. Or, add the user option to the fstab entry to allow any user to mount the floppy, and, as a side effect, the files will appear to be owned by that user. – Mark Plotnick Mar 1 '16 at 22:58
  • @MarkPlotnick - the user option in /etc/fstab is correct. you should post it as an actual answer. – cas Mar 1 '16 at 23:23
  • Yeah was just about to recommend mounting with user or group option – Liam Mar 2 '16 at 0:56
1

Remove the line from /etc/fstab and the gui will correctly mount it. If you also want to be able to mount it from the command line, then add the "user" option to the options list.

  • Thanks to you and to @MarkPlotnick - So adding 'user' to the fstab file enables me to access the floppy drive now via command line. I am still having issues where I can't run the program as a normal user. It needs to be run as 'sudo' otherwise I get a 'permission denied' error? I assume this is still an access issue for the floppy drive and not something to do with the program itself? I have changed my user permissions and ownership of the application so it is all me? – pelagos Mar 2 '16 at 3:00
  • @pelagos, are the files shown as being owned by you? You might also need the uid option Mark suggested.. or you can just remove the entry entirely and the gui will take care of it automatically. – psusi Mar 2 '16 at 23:53
  • no the files are being shown as owned by root and in the group root. No matter how i do it I can't stop this happening. I have not tried setting the UID as yet. Will do that and let you know. The C program I am running is owned by me and I have chmod 777 it so i have every access available but I can still only run the program via command line with sudo ./<appname>. – pelagos Mar 4 '16 at 22:07
  • @pelagos, ok, I thought so... if you have no entry at all and use the gui to mount it, then it automatically adds the uid option.. if you want to be able to mount it from the command line, and set up the entry in /etc/fstab, then it needs the uid option. – psusi Mar 5 '16 at 3:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.