-1

First of all so you understand my knowledge on the matter, I'm a 10-year Mac user and I only run Linux vm's to serve enterprise services. I have never really used Linux X systems, beside gnome once or twice but not with such issues, and so I'm configuring a VM to run some network tools from.

So anyway, I'm running a VM with CentOS 7 & KDE Plasma on VMWare Fusion. It's virtualising a 2-Core 2GB machine with 3D Graphics acceleration and 768 shared video memory.

So initially I set up my desktop with 1920x1200 resolution, but when I rebooted both widgets and windows would go out of format. I figured this was caused by that when GRUB loads (1280x768) and only until after I logon it sets the desktop resolution to 1920x1200. whatever, since I don't like the low-res boot screen because it's still messing the desktop.

So I used the vga= option on boot boot optionsvga=352

And it gives me an error: enter image description heredon't know where it gets the 160 from

And I hit enter: vesa-modesAnd I enter 352 again for 1920x1200x32

So all is ok: enter image description here enter image description here

So I read how to configure grub2 boot resolution

(as root)
$ vim /etc/default/grub

inserted in the end
GRUB_GFXMODE=1920x1200 (also tried with 1920x1200x32)
GRUB_GFXPAYLOAD_LINUX=1920x1200 (also tried with =keep)

; saved, then

$ grub2-mkconfig -o /boot/grub2/grub.cfg
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.10.0-327.10.1.el7.x86_64
Found initrd image: /boot/initramfs-3.10.0-327.10.1.el7.x86_64.img
Found linux image: /boot/vmlinuz-3.10.0-327.el7.x86_64
Found initrd image: /boot/initramfs-3.10.0-327.el7.x86_64.img
Found linux image: /boot/vmlinuz-0-rescue-a5b0b547cfed4198bae524ac4787e0de
Found initrd image: /boot/initramfs-0-rescue-a5b0b547cfed4198bae524ac4787e0de.img
done

and rebooted. What happens is that with this mode the boot resolution is set to the 1280x768 resolution, and only until after the logon the resolution is set to 1920x1200. loading 1280x768loading on res 1280x768 boot screenboot screen on 1280x768 adjusting resolution blue rectangle corresponds to the boot screen resolution when the resolution is properly adjusted

So I'd just like to understand how to properly configure the equivalent of vga=352, but I can't figure out how. I have also tried editing 00_headers on grub.d but that didn't work either.

I can't seem to correctly configure GRUB2 boot to assume the desired resolution.

0

From the details you listed I can see that the value 352 (decimal) is 0x160 (Hex). It looks like the vga option is reading your value as decimal. But the table values on the picture are hex. So if you want to hit the entry 352 (hex) you would need to enter vga=850 (decimal).

  • hi thanks for your answer. I still haven't found a solution for this. but its that GRUB2 looks for GRUB_GFXMODE=1920x1200 GRUB_GFXPAYLOAD_LINUX=1920x1200 and not vga= – Ricardo Mendes Apr 13 '16 at 17:05
  • Would it be possible for you to try with your original approach? – Jonathan Herrmann Apr 13 '16 at 20:24
  • Can you please detail what approach your referring to? sorry – Ricardo Mendes Apr 16 '16 at 22:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.