0

I'm having trouble in a notebook with debian, but for the avoidance of doubt guess I better tell the story of his free-software life (if you do not want to read, jump to problems)

It is a CCE Win i30s, is four years old. It came with an Intel Atom D2500 @ 1.86x2 and Intel GMA 3600 Integrated video adapter (based on the PowerVR SGX 545), and a Realtek wireless rtl8192ce

In 2013 I decided to install a linux on it, but faced many difficulties: Nothing worked My GMA 3600 simply does not work with its drivers/modules open source, only with the owner driver (windows). I tested Ubuntu, Mint, Fedora, Slackware (someone tested to me) and Arch (two days ago) and none of them worked the video: the screen crashs as you can see in the following photo

crash

I posted my problem in n forums, including Intel forum, which they just said to me "My recommendation is to install the operating system validated to discard issues."

At the time the only OS Linux-based that worked was the Debian Wheezy (Jessie or later gave the same error). Yesterday I found out that it works because it uses kernel 3.2, which has no support for the video adapter in the kernel (which was placed from 3.3, according to the Arch Linux wiki)

Xorg loads a generic video module (VESA) and could get the maximum resolution for notebook display (1366x768) without 3D acceleration, but for me it was enough. But had some problems like not expand the display on external monitors (only duplicate), do not come back from a suspension and not change the brightness.

After all this time I decided to play with it again. Installed Debian Wheezy 7.9 with netinst image and not installed the graphics or the network with the installer, I decided to do it by hand to let through 'minimalist' and learn a little about installation.

Anyway, I managed, everything was working as expected on my custom Mate-desktop (with transparency, which the gnome refused to give me in the past)

so I decided to go to fight and upgrade. I arranged so that the kernel was not upgraded (removed the linux-image-686-pae meta-package), I changed the repositories for jessie and did a dist-upgrade

After updated, all normal functioning, despite the same inconveniences previously mentioned. I took courage and after a few reboots did the same process but now for testing

After restarted the notebook, I noticed that the system had changed from SystemV to systemd (testing standard) and that there were improvements! Now multiple resolution options are supported by the notebook display, the expansion to an external screen is working and he returns the suspended state without crashing! (This is the merit SystemV or Xorg?)

problems

However not everything is perfect: the screen is presenting flaws in rendering that are making me nervous. To explain better you can watch the video below:

https://www.youtube.com/watch?v=FeejXdnpr60

I have no idea what it is. Here Xorg.0.log:

(link in comments)

But the worst of the problems are in the wireless network: it is no longer detected. Neither the ifconfig or iwconfig or rfkill detect the wireless adapter, despite the lspci detect and contain it in rules.d

Here the outputs that I found:

# lspci | grep -e -e Ethernet Network
02: 00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe Wireless Network Adapter (rev 01)
03: 00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E / RTL8102E PCI Express Fast Ethernet controller (rev 05)


# ifconfig -a
eth0: flags = 4099 <UP, BROADCAST, MULTICAST> mtu 1500
        Ether 00: e0: 4c: ba: 4b: 74 txqueuelen 1000 (Ethernet)
        RX packets 0 bytes 0 (0.0 B)
        RX errors 0 0 overruns dropped frame 0 0
        TX packets 0 bytes 0 (0.0 B)
        TX 0 errors dropped 0 0 overruns carrier 0 collisions 0
        device interrupt 44 base 0x4000

it: flags = 73 <UP, LOOPBACK, RUNNING> mtu 16436
        inet 127.0.0.1 netmask 255.0.0.0
        inet6 :: 1 prefixlen 128 ScopeId 0x10 <host>
        loop txqueuelen 0 (Local Loopback)
        RX packets 3060 bytes 247696 (241.8 KiB)
        RX errors 0 0 overruns dropped frame 0 0
        TX packets 3060 bytes 247696 (241.8 KiB)
        TX 0 errors dropped 0 0 overruns carrier 0 collisions 0


# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.


# dmesg | grep -e -e rtl eth
[1.914763] r8169 0000: 03: 00.0: eth0: RTL8105e at 0xf8214000, 00: e0: 4c: ba: 4b: 74, XID 00a00000 IRQ 44
[12.290577] rtl8192ce 0000: 02: 00.0: setting latency timer to 64
[22.561203] r8169 0000: 03: 00.0: firmware: agent aborted loading rtl_nic / rtl8105e-1.fw (not found?)
[22.562359] r8169 0000: 03: 00.0: eth0: Unable to load firmware patch rtl_nic / rtl8105e-1.fw (-2)
[22.684870] r8169 0000: 03: 00.0: eth0: link down
[22.685268] ADDRCONF (NETDEV_UP): eth0: link is not ready
[72.915377] rtl8192ce 0000: 02: 00.0: firmware: agent did not handle request for rtlwifi / rtl8192cfw.bin
[72.915475] rtlwifi: rtl_pci_probe ():. <0-0> Can not init_sw_vars


# cat /etc/udev/rules.d/70-persistent-net.rules
# This file was automatically generated by the / lib / udev / write_net_rules
# Program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, the long as you keep each rule on a single
# Line, and only change the value of the NAME = key.

# PCI device 0x10ec: / sys / devices / pci0000: 00/0000: 00: 1C.2 / 0000: 03: 00.0 (r8169)
SUBSYSTEM == "net", ACTION == "add" DRIVERS == ATTR {address} == "00: e0: 4c: ba: 4b: 74" "*?" ATTR {dev_id} == "0x0 "ATTR {type} ==" 1 ", KERNEL ==" eth * ", NAME =" eth0 "

# PCI device 0x10ec: / sys / devices / pci0000: 00/0000: 00: 1C.1 / 0000: 02: 00.0 (rtl8192ce)
SUBSYSTEM == "net", ACTION == "add" DRIVERS == ATTR {address} == "00: 0d: f0: a1: bf: 56" "*?" ATTR {dev_id} == "0x0 "ATTR {type} ==" 1 ", KERNEL ==" wlan * ", NAME =" wlan0 "

I tried a few things like dpkg-reconfigure firmware-realtek, uninstall and re-install the .deb package with dpkg, uninstall and install an older version of the package (which worked) ...

I tried to download the source of the Realtek site and build manually, but I realized that I had neither the build-essential or linux-headers, and, honestly, there is much packages on the dependences to download and install and I think i will not do it, not to mention that the version gcc has to be specifically 4.6 to kernel 3.2 to compile

I do not know what to do, I need help (sorry for the long post and bad english)

0
  • About wifi problem.

    I see [22.561203] r8169 0000: 03: 00.0: firmware: agent aborted loading rtl_nic / rtl8105e-1.fw (not found?)

    So, is there such file in your system (/lib/firmware/rtl_nic/)? Did you try to temporary (re)move /etc/udev/rules.d/70-persistent-net.rules and reboot?

    UPD: Possibly, your updated Debian uses NetworkManager and it grabs the interface first. You can try temporary disable (or uninstall) NM to check wifi-adapter initialization .

Now I`m trying to help with a problem connected with the same GMA3600, and there are many advices and useful links, I think.

  • Outputs: # file /lib/firmware/rtl_nic/rtl8105e-1.fw = /lib/firmware/rtl_nic/rtl8105e-1.fw: data. # file /lib/firmware/rtlwifi/rtl8192cfw.bin = /lib/firmware/rtlwifi/rtl8192cfw.bin: data – 648trindade Mar 2 '16 at 0:43
  • I moved the file to another directory (my root home dir) and rebooted, but nothing was changed – 648trindade Mar 2 '16 at 1:18
  • @648trindade I update my answer, see it. – approximatenumber Mar 2 '16 at 8:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.