I'm running a server (VPS) with Debian 8.3 (jessie) and systemd manages different processes. The load of the system is below 1, but it uses nearly all memory and some share of swap space. When I try to stop a service and enter

systemctl stop process@1

the logfile says

Mar  1 08:03:50 abcde systemd[1]: Looping too fast. Throttling execution a little.

This message appears every second and nothing more happens. When I send ^C to the terminal, the process is finally stopped. The same happens when I try to restart a daemon. Systemd has version: 215-17+deb8u3

Why does this message appear and what can I do to shutdown a daemon without this message?

3 Answers 3


According to this issue with systemd on github, the problem may be with dbus, and upgrading systemd is recommended as the version that comes with Debian 8 (version 215) is considered old as of July 2015.

You could try rebooting the server, as that has fixed this problem for some others that have run into this issue (though this is obviously just a workaround). There are also some other fixes/workarounds on the report I listed that may apply in your situation.


According to this thread on bugs.debian.org, the fixes for this should be available in the 215-17+deb8u5 version of the systemd package. Upgrading to this version should solve your issue.


I had similar problem.

systemctl daemon-reexec

cleaned it up. I tried to compare the output of

systemctl --all

before and after I ran the reexec. What I see before the reexec is a large number of lines like:

session-1046.scope       loaded inactive dead   start Session 1046 of user root
session-1047.scope       loaded inactive dead   start Session 1047 of user root
session-1048.scope       loaded inactive dead   start Session 1048 of user root
session-1049.scope       loaded inactive dead   start Session 1049 of user myuser
session-1050.scope       loaded inactive dead   start Session 1050 of user root
session-1051.scope       loaded inactive dead   start Session 1051 of user root
session-1052.scope       loaded inactive dead   start Session 1052 of user myuser

These all disappeared after the reexec. I believe they have something to do with execution of:

ssh root@myserver
ssh myuser@myserver

Over a number of weeks since last reboot.

I could reproduce the systemctl entry in the "running state" by logging in as root (or myuser), but if I properly exit or kill the window the entry disappears. I expect that if I leave the login it eventually hangs in some fashion leaving behind the systemD session. Not sure if these have anything to do with the looping of systemD though.


That means that systemd is trying to start a service, it crashes (or finishes normally) immediately. Trying to restart it leads to the same, thus the message. Check if some configuration is wrong/missing, some files aren't found at the expected place/wrong permissions, ...

  • 1
    I'm trying to stop a service when the message comes and the job is done when I press ^C. The configuration is correct. I double-checked it.
    – qbi
    Commented Mar 1, 2016 at 21:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .