10

I've enabled tap-to-click in Gnome but it doesn't work on GDM.

I tried running dconf-editor as root to modify the setting but to no avail.

I also tried running sudo -u gdm gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click true but I get the following error

(process:16560): dconf-WARNING **: failed to commit changes to dconf: Error spawning command line 'dbus-launch --autolaunch=long-number-here --binary-syntax --close-stderr': Child process exited with code 1

How do I enable tap-to-click on GDM?

1
  • I don't know about GDM but this has worked on every Arch version I've tried it on: forums.kali.org/…
    – John S
    Dec 15, 2016 at 17:53

1 Answer 1

9

You have to export $(dbus-launch) and set the gsettings backend (tested on archlinux with gdm 3.18.2):

  1. switch to a VT (e.g. Ctrl+Alt+F3), login as root and run:

    su - gdm -s /bin/sh
    

    to switch user to gdm.

  2. then run:

    export $(dbus-launch)
    

    and:

    GSETTINGS_BACKEND=dconf gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click true
    

    run exit or hit Ctrl+D to return to root account.

  3. restart the display manager:

    systemctl restart gdm
    

Reverting is pretty much the same, just change true to false @ step 2.

5
  • In Debian Stretch switch user to Debian-gdm: su - Debian-gdm -s /bin/sh
    – Sławek
    Jan 21, 2017 at 18:57
  • so how do you persist these settings?
    – iLemming
    May 10, 2018 at 6:05
  • Confirmed working on Fedora 30.
    – Zhro
    Aug 25, 2019 at 14:52
  • thank you (F35)
    – Sebastian
    Dec 9, 2021 at 0:55
  • @Sławek what about Pop! Os? 2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.