1

I updated my Debian Jessie installation a few days ago to the current minor version (8.3), which included a new Linux kernel (uname -a gives 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17) x86_64 GNU/Linux). Since then, I haven't been able to connect to the Internet, which previously had not been a problem. The same ethernet cable and port quickly connects to the Internet (using DHCP) if I plug it into a Macbook or even an ancient CentOS machine, so the problem must be in the Debian configuration. I'm at a loss for what to do though. I tried different combinations of DHCP or static IP (using the IP address and settings obtained with DHCP on the other machines), and ifupdown or network-manager, along with several reboots, all to no avail. DHCP fails either silently or with a message about not obtaining a lease. With a static IP, the ethernet device shows up as connected, but in fact there is no connection to the Internet. Any ideas for how to go about troubleshooting?

Edit: Here are the lines that seem possibly relevant in /var/log/dmesg [eth1 is the right port]:

[ 16.480813] ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 18.031149] tg3 0000:08:00.0: eth1: Link is up at 100 Mbps, full duplex
[ 18.031151] tg3 0000:08:00.0: eth1: Flow control is off for TX and off for RX
[ 18.031881] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 28.240006] eth1: no IPv6 routers present

Output of nmcli -p -f general device show eth1:

===============================================================================
                             Device details (eth1)
===============================================================================
GENERAL.DEVICE:                         eth1
GENERAL.TYPE:                           ethernet
GENERAL.VENDOR:                         Broadcom Corporation
GENERAL.PRODUCT:                        NetXtreme BCM5754 Gigabit Ethernet PCI Express (Precision T5400)
GENERAL.DRIVER:                         tg3
GENERAL.DRIVER-VERSION:                 3.137
GENERAL.FIRMWARE-VERSION:               5754-v3.24
GENERAL.HWADDR:                         00:21:9B:41:28:86
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.0/0000:08:00.0/net/eth1
GENERAL.IP-IFACE:                       eth1
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.CONNECTION:                     eth1
GENERAL.CON-UUID:                       c81bfd1d-5dad-4ba0-9160-b6dba7ea325a
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/2

Output of ethtool eth1:

Settings for eth1:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Advertised pause frame use: Symmetric
    Advertised auto-negotiation: Yes
    Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                         100baseT/Half 100baseT/Full 
    Link partner advertised pause frame use: No
    Link partner advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    MDI-X: off
    Supports Wake-on: g
    Wake-on: g
    Current message level: 0x000000ff (255)
                   drv probe link timer ifdown ifup rx_err tx_err
    Link detected: yes

Output of lsmod | grep tg3:

tg3                   164481  0 
ptp                    17692  1 tg3
libphy                 32268  1 tg3

Output of lspci | grep -i ethernet:

08:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5754 Gigabit Ethernet PCI Express (rev 02)

Output of cat /var/log/kern.log | grep -i tg:

May 15 12:00:14 kernel: [    2.587463] tg3.c:v3.116 (December 3, 2010)
May 15 12:00:14 kernel: [    2.587482] tg3 0000:08:00.0: PCI INT A -> GSI
 16 (level, low) -> IRQ 16
May 15 12:00:14 kernel: [    2.587491] tg3 0000:08:00.0: setting latency 
timer to 64
May 15 12:00:14 kernel: [    2.604699] tg3 0000:08:00.0: eth0: Tigon3 [pa
rtno(BCM95754) rev b002] (PCI Express) MAC address 00:21:9b:41:28:86
May 15 12:00:14 kernel: [    2.604702] tg3 0000:08:00.0: eth0: attached P
HY is 5787 (10/100/1000Base-T Ethernet) (WireSpeed[1])
May 15 12:00:14 kernel: [    2.604704] tg3 0000:08:00.0: eth0: RXcsums[1]
 LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
May 15 12:00:14 kernel: [    2.604706] tg3 0000:08:00.0: eth0: dma_rwctrl
[76180000] dma_mask[64-bit]
May 15 12:00:14 kernel: [   13.668551] tg3 0000:08:00.0: irq 78 for MSI/M
SI-X
May 15 12:00:14 kernel: [   15.265188] tg3 0000:08:00.0: eth1: Link is up
 at 100 Mbps, full duplex
May 15 12:00:14 kernel: [   15.265190] tg3 0000:08:00.0: eth1: Flow contr
ol is off for TX and off for RX

output of ethtool -S eth1:

NIC statistics:
 rx_octets: 1351463
 rx_fragments: 0
 rx_ucast_packets: 0
 rx_mcast_packets: 1051
 rx_bcast_packets: 8167
 rx_fcs_errors: 0
 rx_align_errors: 0
 rx_xon_pause_rcvd: 0
 rx_xoff_pause_rcvd: 0
 rx_mac_ctrl_rcvd: 0
 rx_xoff_entered: 0
 rx_frame_too_long_errors: 0
 rx_jabbers: 0
 rx_undersize_packets: 0
 rx_in_length_errors: 0
 rx_out_length_errors: 0
 rx_64_or_less_octet_packets: 0
 rx_65_to_127_octet_packets: 0
 rx_128_to_255_octet_packets: 0
 rx_256_to_511_octet_packets: 0
 rx_512_to_1023_octet_packets: 0
 rx_1024_to_1522_octet_packets: 0
 rx_1523_to_2047_octet_packets: 0
 rx_2048_to_4095_octet_packets: 0
 rx_4096_to_8191_octet_packets: 0
 rx_8192_to_9022_octet_packets: 0
 tx_octets: 106305
 tx_collisions: 0
 tx_xon_sent: 0
 tx_xoff_sent: 0
 tx_flow_control: 0
 tx_mac_errors: 0
 tx_single_collisions: 0
 tx_mult_collisions: 0
 tx_deferred: 0
 tx_excessive_collisions: 0
 tx_late_collisions: 0
 tx_collide_2times: 0
 tx_collide_3times: 0
 tx_collide_4times: 0
 tx_collide_5times: 0
 tx_collide_6times: 0
 tx_collide_7times: 0
 tx_collide_8times: 0
 tx_collide_9times: 0
 tx_collide_10times: 0
 tx_collide_11times: 0
 tx_collide_12times: 0
 tx_collide_13times: 0
 tx_collide_14times: 0
 tx_collide_15times: 0
 tx_ucast_packets: 492
 tx_mcast_packets: 30
 tx_bcast_packets: 995
 tx_carrier_sense_errors: 0
 tx_discards: 0
 tx_errors: 0
 dma_writeq_full: 0
 dma_write_prioq_full: 0
 rxbds_empty: 0
 rx_discards: 0
 rx_errors: 0
 rx_threshold_hit: 0
 dma_readq_full: 0
 dma_read_prioq_full: 0
 tx_comp_queue_full: 0
 ring_set_send_prod_index: 0
 ring_status_update: 0
 nic_irqs: 0
 nic_avoided_irqs: 0
 nic_tx_threshold_hit: 0
 mbuf_lwm_thresh_hit: 0

output of iptables -vL:

Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination
  • Do the logs have anything to say? Have you tried a different kernel version? – Faheem Mitha Feb 29 '16 at 15:59
  • Which logs? I tried the other kernel available on startup, 3.2.0, but it didn't seem to make a difference. – Nir Feb 29 '16 at 16:02
  • Try /var/log/dmesg. Debian currently has 4.3 and 4.5 kernel images available. It seems unlikely the kernel is the problem, but it doesn't hurt to try. If you want to hop into the main chat room, it might facilitate debugging. You can ping me there if you want. – Faheem Mitha Feb 29 '16 at 16:05
  • I could try different kernel versions, but I'd rather not deviate too much from a standard Stable installation, not to mention that it would logistically cumbersome without Internet. – Nir Feb 29 '16 at 16:20
  • You don't happen to have any iptables rules (iptables -vL to check) that might be blocking connectivity? – derobert Feb 29 '16 at 22:00
1

1) Try to rewrite resolv.conf at boot time by adding an echo in rc.local , as root type:

echo "nameserver ip.addres.of.dns" > /etc/resolv.conf

ip.addres.of.dns = ip_router

2)Back up interfaces file

sudo cp /etc/network/interfaces /etc/network/interfaces.copy

Edit /etc/network/interfaces

it will be something like (example) :

/etc/network/interfaces# This file describes the network interfaces available o$
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
    address 91.121.0.0
    netmask 255.255.255.0
    network 91.121.0.0
    broadcast 91.121.0.255
    gateway 91.121.0.254
    dns-nameservers 8.8.8.8 8.8.4.4

Update: for IPV6 an example:

  iface eth0 inet6 static
    address 2001:db8::c0ca:1eaf
    netmask 64
    gateway 2001:db8::1ead:ed:beef

Restart the Network:

sudo service networking restart
  • Thanks for these ideas. For (1), could it really be a DNS issue, if there’s no connectivity even just using IP addresses, like in ping -c 5 8.8.8.8? For (2), I already tried editing /etc/network/interfaces with what I think are the correct settings and restarting, with no luck. – Nir Feb 29 '16 at 16:43
  • try to disable ipv6 in kernel: echo net.ipv6.conf.all.disable_ipv6=1 > /etc/sysctl.d/disableipv6.conf OR sudo sysctl -w net.ipv6.conf.eth0.disable_ipv6=1 – GAD3R Feb 29 '16 at 17:29
  • Thanks. Disabling ipv6 doesn't seem to help, even after rebooting. – Nir Feb 29 '16 at 18:29
  • try to renew or release an IP to eth0: sudo dhclient -r eth0 and sudo dhclient eth0 – GAD3R Feb 29 '16 at 18:56
  • those run with no messages printed, but Internet still doesn't work – Nir Feb 29 '16 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.