1

I've created a user called "ftp-acc" and limited it to a single directory using VSFTPD. When I login to the account in Filezilla using FTP, it is successfully restricted to a single directory.

However, when logging in with the same credentials using SFTP, the user can access other directories as well.

How can I disable SFTP for the user "ftp-acc"?

2

First point , FTP and SFTP both are different. FTP normal file transfer protocol but SFTP is secure file transfer protocol and this service is from SSH not a stand alone service.

If you want to disable SFTP for one user then open sshd_config file in server(machine you are trying to access) and

DenyUsers ftp-acc

and then restart sshd service with

service sshd restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.