1

I'm trying to install xubuntu on a usb flash drive following this quide. The command I'm running is

qemu-system-x86_64 -drive file=/dev/sdc,media=disk,index=0,format=raw -cdrom ./xubuntu-15.10-desktop-amd64.iso -boot menu=on

/dev/sdc is my usb drive formatted as ext4. It starts to boot from xubuntu*.iso, as I can see this screen

But then I get kernel panic

enter image description here

I was able to boot this image with virtualbox, though. Which partition is it tring to mount? This must have nothing to do with /dev/sdc, or not? What am I doing wrong? Any clues?

  • the guide says not to format your destination /dev/sdc usb disc as the installed will try to avoid accidentally overwriting an existing system. – meuh Feb 28 '16 at 18:46
  • @meuh, what exactly do you suggest? I don't have Disk Utility. Should I do dd if=/dev/zero of=/dev/sdc bs=... count=...? – x-yuri Feb 28 '16 at 22:55
  • I think that is worth a try (I dont have or know what the Disk Utility does either). – meuh Feb 29 '16 at 7:40
  • I ran dd if=/dev/zero of=/dev/sdc iflag=nocache oflag=direct bs=4096 before starting qemu, but nothing changed. – x-yuri Mar 13 '16 at 13:11
3

It seems this obscure error is due to the ramdisk of the kernel image having grown so much these days that it no longer fits in the default size for ram memory of the qemu virtual machine (which is quite low at 128 MiB). Simply add a memory option like:

-m 512M

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.