2

It seems to be available here.

But when I try the following command:

$ sudo pacman -S mit-scheme

I get the following:

error: target not found: mit-scheme

I've also tried with mit-scheme-git (from here), since that seems more recently updated, but I got the same result.

Is there some other package I should be installing? Or do I need to do it without using the package manager?

1 Answer 1

5

Update 1/28/19:

The package has been added to the community repository of Arch. It lives here. It can be installed with a simple sudo pacman -S mit-scheme.


Original answer

That package doesn't seem to be available in any of the default repositories.

To install it navigate to the AUR page (https://aur.archlinux.org/packages/mit-scheme/) and click "Download Snapshot".

Once you have the tar of the snapshot untar it.

tar -xf yourfile.tar

Then run the command makepkg on the PKGBUILD located within the extracted archive.

makepkg PKGBUILD

That should leave you with a pkg that you can install using the

pacman -U pkg-goes-here.pkg command. 

Yaourt is also a good way to download software not available in a repository.

3
  • 1
    Adding specific links would be helpful here. Commented Feb 28, 2016 at 15:33
  • This is definitely out of date. The package exists in the community repo. archlinux.org/packages/?name=mit-scheme
    – mas
    Commented Jan 28, 2019 at 17:54
  • The edit is out of date again, now mit-scheme is back to AUR and thus the original answer is more correct.
    – DDMC
    Commented Jun 19, 2021 at 9:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .