1

I have an Edimax EW-7811Un wireless adapter which I am trying to get to work on my laptop which is running Debian 8.3.0 with LXDE. I have tried various things that I am going to describe below. But first I a want to say where I am stuck right now. Its that lshw -C network shows the wrong driver rtl8192cu which I blacklisted. Instead I installed the driver 8192cu (without the rtl prefix).

lsusb | grep -i edimax shows the following

Bus 001 Device 006: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

So, it uses a Realtek RTL8188CUS chip. A quick search in the Internet says that it uses the same driver as RTL8192CU.

I installed rtl8192cu-fixes driver according to these instructions. The instructions say that I am supposed to blacklist the rtl8192cu and rtlwifi modules that come with the Linux kernel, so I did so.

The new driver 8192cu loads fine, the lsmod | grep -i 8192cu output is:

8192cu                520192  0 
usbcore               233472  10 uas,btusb,uvcvideo,usb_storage,ehci_hcd,ehci_pci,usbhid,8192cu,xhci_hcd,xhci_pci

I enabled the adapter or driver (I am not quite sure which) with sudo ifconfig wlan1 up, because sudo lshw -C network was listing it as DISABLED.

Because there was a soft block when writing sudo rfkill list all I typed sudo rfkill unblock all.

Now the only thing that is left is letting Linux know that the right driver for my wireless adapter is 8192cu and not rtl8192cu...

The current sudo lshw -C network output is (the relevant part):

  *-usb:0                 
       description: Wireless interface
       product: 802.11n WLAN Adapter
       vendor: Realtek
       physical id: 2
       bus info: usb@1:2
       logical name: wlan1
       version: 2.00
       serial: 00e04c000001
       capabilities: usb-2.00 ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192cu maxpower=500mA multicast=yes speed=480Mbit/s wireless=unassociated

Please note especially the last line where it says driver=rtl8192cu... :(

PS: Oh, yeah I forgot to mention that I did a Linux kernel upgrade, because that worked with another driver problem I had (backlight for a very new Intel CPU). But there weren't any results this time... :(

Edit: When I don't blacklist the Linux kernel modules rtl8192cu and rtlwifi the LED of the wireless adapter is always on, but the network manager WICD does not find any routers.

Edit2: On another laptop with the same OS and desktop (Debian + LXDE) it didn't work, either. But I also had Lubuntu 15.10 installed there, and the wireless adapter works with it. Lubuntu uses the rtl8192cu driver that comes with the kernel.

  • 1
    You might make some progress using the bind functionality in sysfs, as seen here, or new_id as in echo 7392 7811 > /sys/bus/usb/drivers/8192cu/new_id – Wumpus Q. Wumbley Feb 28 '16 at 2:52
0

I followed the link that Wumpus Q. Wumbley provided in his comment, and after reading the question and some additional articles I found out that my driver was correctly recognized as it should be, but the developers of the driver 8192cu decided to let the system think that the rtl8192cu driver is being used by keeping the folder structure and just symlinking to the new driver 8192cu.

I then tried it with command line tools to scan for wireless routers as described in the article Wi-Fi on the command line and to my surprise my adapter found them alright.

Then I checked again with my Wicd Network Manager program, and found out that in the settings only wlan0 (my PCI network card) was used, so I switched to wlan1, and Internet works now.

Initially the wireless speed was like 80KB/s in local network. It was plugged at a USB 3 port. I plugged it to a USB2 port, and the speeds are about 1-2MB/s. Still quite slow, but at least functional.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.