0

This question already has an answer here:

I am looking for hints on this problem. I've searched around, but can't find something exactly similar.

I am running Debian 8 stable, updated, very minimal install (i3wm, small number of apps running) on a 4yr laptop. While doing some web browsing it crashed - black screen showing swap partition errors (I did not make a note and could not take a picture unfortunately). It stayed like that for a while, and I left the computer be, but after a few minutes I tried switching TTYs and was able to come back to the window manager (other TTYs were black). I could open a new tab in a terminal and tried running some commands like dmesg and tried to look in /var/ and /run/. But every command would result in a seg fault without running. lsblk, mount, dmesg grep - everything was seg faulting OR giving input/output error. For example, lsblk would give input/out error. I could not reboot without pressing the power key.

It seemed like (just a guess) that almost everything that was already in memory at the time (like the terminal, WM, wireless, htop) was able to run, but any IO to disk and some memory accesses failed. That potentially brings up several levels of issues, but I can only guess from theory and not sure if they are possible (maybe even invalid read to a single memory plank/block - guesses along those lines). I am thinking memory issues because of the seg faults on common applications, but that could also mean multiple things.

It is a long shot, but maybe someone has seen something like this. I've had a very similar problem with input/out error sometime ago on the same machine, but it happened only once, and I did not think of it much. I ran badblocks with 0 bad blocks found.

I am a comp sci student, but troubleshooting Linux errors like this is not something I got to do a lot. I can get technical, but I don't know where to look. I can post the right logs (still looking through syslog to find something) on demand. I would really appreciate some help/hints.

Thanks in advance.

marked as duplicate by Gilles debian Feb 28 '16 at 18:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Given that this description is very generic, I'm closing this question as a duplicate of a question with similarly generic symptoms. If you have more precise concerns, e.g. a reproducible situation or some exact error messages, edit your question and we can reopen it. – Gilles Feb 28 '16 at 18:33
0

Some ways to debug:

  • Boot with a rescue disk / live disk and check if the system is stable. Could be hardware problem in particular memory

  • fsck all filesystems and repair. Check in lost+found and in general in filesystem if some important files are missing

  • check your logs (/var/log), on the /var of your system (not of you rescue disk) to see if you identify the cause.

  • a chroot to your system root could help interactively to find problems, and fix them using outside terminal

Not the answer you're looking for? Browse other questions tagged or ask your own question.