0

First, I noticed frequent hang ups with the mouse when using scp in local network. I checked RAM usage, but free -m showed me about 33% usage without buffers/caches. (I have 8G RAM.) The CPU usage was about 10% according to top, and IO usage was also just a 2-3 MiB per second (iotop).

I thought maybe there might be a problem with the USB mouse, but then I noticed that videos freeze at the same time the mouse hangs, so I searched in the Internet whether there might be problems with xorg when there is a high network usage, but I didn't find anything relevant.

I am also not sure whether it is just the screen or the whole system that is hanging. Is there a way to find out the cause of those hang ups? I get them every few seconds for the fraction of a second to a whole second.

I am using Debian 8.3.0 with LXDE. When I don't use scp or copy files with rsync with ssh there are no problems.

Edit: This guy had the same issue as me. Just like him I don't have any problems when I use wired connection, only when I use wireless connection. When using scp I also have high network bandwidth, so even that seems to be similar to his problem. He solved it by changing his wireless card, but I cannot do the same, because I have notebook...

lspci | grep -i wireless gives me:

08:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

I am suspecting that either the drivers are bad, or this card generally has problems. I will look into it.

Edit2: I replaced the drivers to that wireless card according to the instructions in this site, because I had trouble getting wireless Internet to work. Since then I had no trouble with the Internet connection, except now the problem above.

Edit3: I took a look at dmesg from when my wireless driver rtlwifi/rtl8723befw.bin was loaded. Here the for the first time wireless and wired connection is checked. Here every time wireless or wired connection is mentioned. Wireless connection stopped at 3046.369442 for some reason (Reason: 7=CLASS3_FRAME_FROM_NONASSOC_STA). (I didn't notice that actually.) Then two times because of wlan0: cannot understand ECSA IE operating class 0, disconnecting at 18999.828397 and 25253.740790 after I did sudo modprobe iwlwifi 11n_disable=1. I stopped wlan once to test wired connection and after I reconnected with wlan and did the 11n_disable=1 immediately after. Since then I didn't notice any big hang ups (only small ones that are almost unnoticable), even though I have scp running on two terminals, but the connection seems to break occasionally. Between the sectiones I quoted there is not much activity. To be sure I will upload the whole dmesg output starting from the first time wlan0 gets up: dmesg output

I don't think there were was anything on dmesg when the hang ups happened.

I will keep testing scp, check if wireless connection breaks again, or if there are any hang ups, and report it. And I will also try a wifi USB key. I am pretty sure I won't have any problems then.

Edit4: I tried with the wireless adpater Edimax-7811Un and the freezes are a lot more severe there. While I only had very short hang ups with RTL8723BE, I have total freezes now without recovery. I have to use the power button to shut down the computer. (Well, just once I managed to reboot with ALT+Sysrq+B, but not a second time.)

This bug report for an old Ubuntu version with kernel 2.6.28 describes similar problems. Some people solved it with downgrading to the 2.6.27 kernel. I, however, had the initial light problems with the kernel version 3.16.0-4-amd64. Trying to get the wireless adapter to work with Debian, I upgraded the kernel to 4.3.0-0. And now I get total system freezes when there are problems with the network. I will test if I get the freezes, too, when I use the 3.16.0-4 kernel.

Also, there were never any problems when using wired connection.

Edit5: I recompiled the driver rtl8723be from lwfinger's git repository on the newer kernel 4.3.0-0, and I don't have any hang ups anymore. The speed of wireless transfer from a computer that is directly connected to my router with a LAN cable to my laptop is about 4-5MB/s. The problem seems to be solved now.

  • Does anything appear in the kernel logs? Either at each freeze, or perhaps just at the first freeze after boot. There could also be something relevant during boot when the driver is initialized but that may be harder to find. – Gilles Feb 26 '16 at 21:35
-1

Suspectiong that the problem caused by X server, try to change the variable ForwardX11Trusted yes to no in /etc/ssh/ssh_config

  • It is not the X server. I have no problems when using wired connection. See above edit of my question. – mkdrive2 Feb 26 '16 at 16:44
  • in that case I would recomend to rebuild module from this repo https://github.com/lwfinger/rtlwifi_new/ and then reboot and unload/load module sudo modprobe -r rtl8723be and then sudo modprobe rtl8723be – Ivan Temchenko Feb 26 '16 at 16:49
  • I did exactly that, because I had trouble with wireless connection. I had no trouble with Internet connection since, except the problem above. I forgot to mention it in my last edit. I am suspecting it is bad drivers after all, or the wireless card just sucks... :( – mkdrive2 Feb 26 '16 at 16:51
  • 2
    try disabling sudo modprobe iwlwifi 11n_disable=1 if enabled – Ivan Temchenko Feb 26 '16 at 16:57
  • I tried it, and it still hangs sometimes. I am not really sure if it has improved a little, though. – mkdrive2 Feb 26 '16 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.