XFA forms are features of a pdf file involving options to complete fields in certain documents - in many cases official documents. These options may open a calendar, for example, in order to select day, month and year, etc. Usually these forms ensure that a certain official format is used.

I have seen that Okular displays a warning that XFA forms are not supported:

enter image description here

More here.

Selecting 'Show forms' in Okular those fields can be edited and changes can be saved, but comparing to what I see in Windows with Adobe Reader only some part of those are really accessed in this way: the calendar options are absent, and the separate fields of day/month/year are not present, which may raise questions on the correctness of the result.

Adobe Reader 9 can still be installed in Ubuntu 14.04 but this seems like a very limited option.

Is there a a native pdf reader that can use fully XFA forms?

(If not, is Wine a solution?)


The solution for Ubuntu 14.04 works in 16.04. too.


The file I tested was here.

up vote 11 down vote accepted
  • Master PDF Editor for Linux has a free and a commercial version, and even the free version has many advanced features, among which "Dynamic XFA form support".

  • Playonlinux has an option to install Adobe Acrobat Reader DC. But oddly, only letting PoL download and install the program works, while when selecting the latest version (AcroRdrDC1700920044_en_US) of the exe file previously downloaded locally the installation fails with an error. I have noticed this on several occasions, and also that PoL installs a different older version: 2015.010.20056.

  • In Ubuntu-16.04-systems the method of installing Adobe Reader 9 for 14.04 (link in question body) still works.


As suggested in Chris' answer, the newer versions of Evince/GNOME Document Viewer, can better handle XFA files, and good enough for the file in question - tested version 3.24.0.

  • Master PDF Editor for Linux RPM works on Mageia 5. It is awkward to have two answers in one as +1 doesn't tell the reader which one the respondant is voting for. – kbulgrien Apr 15 '17 at 18:08
  • For 14.04 installing Adobe Reader worked. As I have not tested Master PDF I decided to not use +1/ – Mateusz Konieczny Apr 26 '17 at 10:28
  • My vote is for Master PDF Editor, tested v. 4.1.30 in Manjaro Linux (up-to-date as of August 22nd 2017) 17.0.2. Worked without a hitch, except the date selector is funky, but no obstacle to filling the form – Bennypr0fane Aug 22 '17 at 11:59

evince works for some XFA files. I just tried it on two and it worked just fine on one, but with the other I got a page that said to download Adobe Reader.

  • ... that is a fatal and embarrassing limit of my now old question. I had a XFA file that was not well handled by Evince, but the program is often updated. I have to find that file and test again to be able to confirm. – cipricus May 3 '17 at 20:04
  • Indeed. GNOME Document Viewer 3.24.0 has a rather good support now for that type of file. - Thank you. – cipricus May 3 '17 at 20:12
  • Testing again on that file and comparing with Master PDF and Adobe Reader DC, I can say that Evince works, but still falls a bit behind (as I mentioned in the question in relation to Okular, the separate fields of day/month/year are not seen as well as in the other apps, which may be misleading as to the result). That may depend on the variations in the XFA files. – cipricus May 3 '17 at 20:41

I was able to fill XFA forms with "Acrobat Reader DC Reader" with Wine. I've installed it using PlayOnLinux. The installed version is: 15.10.20056.167417 and can be downloaded at ftp://ftp.adobe.com/pub/adobe/reader/win/AcrobatDC/1501020056/. It let me fill XFA forms that with any native Linux PDF reader I couldn't even print the forms for filling it manually.

  • When trying to install in Playonlinux from that package downloaded manually I get an error. -- But the installation works fine when I choose the option of letting Playonlinux download automatically the package before installing, although it seems to be exactly the one mentioned above. – cipricus Mar 24 '17 at 10:09

Adobe Reader 9 can be installed in 14.04 and 16.04 - see https://askubuntu.com/questions/767937/how-to-install-adobe-acrobat-in-ubuntu-16-04 (works also for 14.04).

Had a .pdf form with XFA fields I couldn't fill in. Downloaded and installed Master-pdf, free version:

master-pdf-editor-4.2.12_qt5.amd64.deb 

Did the trick, at least with the form I needed. I'm running:

$ uname -a
Linux debianHP 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2+deb8u1 (2017-06-18) x86_64 GNU/Linux
  • This fits more as comment to the accepted answer, as it is already mentioned there. – cipricus Jun 25 '17 at 11:24

I am not aware of any PDF viewer besides Adobe products which can properly work with XFA forms. (I may be wrong on this; would not be the first time…).

If Adobe Reader 9 for Ubuntu is feature equivalent with Adobe Reader for Windows or Mac, it should be able to open and work with XFA forms. Saving, however, depends on whether the issuer of the form has applied Extended Reader Rights.

If the feature equivalence is not given, then your only choice is establishing a virtual Windows machine and run Adobe Acrobat/Reader. Saving with Reader may still be the issue, however.

  • I think there is a huge difference between actual documents. While I also have read that only Adobe Reader fully supports XFA, on the other hand very few documents use all the XFA features. That is, readers that support only partially XFA may be enough in practice to use such documents. – cipricus Feb 27 '16 at 20:05

Foxit Reader works just fine in Wine without all the tinkering and patching needed to make Adobe work. There is also a native Linux version of Foxit, but it lacks most of the advanced features and is thus just another simple PDF viewer. Download from: http://download.cnet.com/Foxit-Reader/3000-18497_4-10313206.html Foxit's own pages won't let you choose the Windows version if it detects a Linux client.

PDF Studio Viewer, Qoppa's free PDF reader, can fill interactive forms and includes JavaScript support.

It does have support for static xfa forms but not dynamic forms.

https://www.qoppa.com/pdfstudioviewer/download/

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.