3

I have a workstation running under Debian testing (stretch). I need to access it from outside my local network, and due to not having a static public IP nor ability to use full port forwarding, for years I've been using Hamachi to access my machines remotely.

Unfortunately on Debian Stretch I can't seem to be able to install the logmein-hamachi package from logmein labs. There is an unsatisfied dependency - lsb-core, which isn't in the stretch repo anymore.

The logmein-hamachi package is from logmein labs: https://secure.logmein.com/labs/logmein-hamachi_2.1.0.139-1_amd64.deb

This is what happens when I try installing the package in question:

sudo dpkg -i logmein-hamachi_2.1.0.139-1_amd64.deb 
(Reading database ... 177847 files and directories currently installed.)
Preparing to unpack logmein-hamachi_2.1.0.139-1_amd64.deb ...
Unpacking logmein-hamachi (2.1.0.139-1) over (2.1.0.139-1) ...
dpkg: dependency problems prevent configuration of logmein-hamachi:
 logmein-hamachi depends on lsb-core (>= 3.0); however:
  Package lsb-core is not installed.

dpkg: error processing package logmein-hamachi (--install):
 dependency problems - leaving unconfigured
Processing triggers for systemd (228-6) ...
Errors were encountered while processing:
 logmein-hamachi

Of course I tried installing lsb-core, but it's not in repo anymore (afaik it's been dropped for Debian releases any newer than Jessie):

sudo aptitude install lsb-core
No candidate version found for lsb-core  
No candidate version found for lsb-core
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

Has anyone tried to install it or maybe knows how to trick Hamachi into installing and working without it?

The output of dpkg run on the deb is. It looks like a source is not available here.

dpkg --info logmein-hamachi_2.1.0.139-1_amd64.deb 
 new debian package, version 2.0.
 size 1322196 bytes: control archive=1004 bytes.
      28 bytes,     1 lines      conffiles            
     529 bytes,    15 lines      control              
     454 bytes,     7 lines      md5sums              
     312 bytes,    12 lines   *  postinst             #!/bin/sh
     209 bytes,    11 lines   *  prerm                #!/bin/sh
 Package: logmein-hamachi
 Source: hamachi
 Version: 2.1.0.139-1
 Architecture: amd64
 Maintainer: LogMeIn <hamachilinux-feedback@logmein.com>
 Installed-Size: 3184
 Depends: lsb-core (>= 3.0)
 Section: net
 Priority: extra
 Description: LogMeIn Hamachi
  LogMeIn Hamachi is a hosted VPN service that securely connects
  devices and networks, extending LAN-like network connectivity to
  mobile users, distributed teams and business applications. You can
  easily create secure virtual networks on demand, across public and
  private networks.
  • Can you provide more information? The following would be helpful. (a) A link to the deb file in question. If the source deb is available, please provide a link to that too. You might be able to rebuild it on stretch. (b) the exact commands you typed + error messages. – Faheem Mitha Feb 25 '16 at 10:20
  • I edited the question. Link to the package file + commands + errors are now included. – Jakub Feb 25 '16 at 10:50
  • Rebuilding the package yourself with appropriate modifications would probably be your best bet. I don't know anything about this software. Is the source available? If not, manually disassembling the deb, editiing the relevant file to modify runtime dependencies, and then reassembling is also an option, but then of course, the question remains of why lsb-core is a requirement. I suggest you talk to the distributors. They're really the only people who can answer these questions. – Faheem Mitha Feb 25 '16 at 11:23
2

This may be a bit late, but "[Hamachi] can now be installed without [the] LSB package."

  • Accepted as this is a solution now. – Jakub Jun 13 '16 at 6:29
3

It does indeed appear that lsb-core is not currently in stretch. See https://packages.debian.org/search?keywords=lsb-core&searchon=names&suite=all&section=all

Also the changelog says (in the lsb (9.20150826)) entry,

Drop all the LSB compatibility packages besides lsb-release and lsb-base

At this point, your best bet would be as follows.

  1. Talk to the maintainers/developers/distributors about this issue. They may care. (a) I would ask them whether they can provide you the source deb to modify. The answer will probably be no. (b) Whether they can make a deb package for you that will work with the current stretch. (c) Why lsb-core is required.
  2. If you get no joy from them, you could try manually disassembling the deb, editing the relevant file to modify runtime dependencies, and then reassembling. However, of course, the question remains why lsb-core is a requirement.
  • Debian giving up on LSB (which is why that package was removed): lists.debian.org/debian-lsb/2015/09/msg00008.html – muru Feb 25 '16 at 11:53
  • @muru Well, that's a shame. – Faheem Mitha Feb 25 '16 at 11:55
  • It might be possible to just create an equivs package, or install Jessie's lsb-core package by downloading it directly. Given the contents of lsb-core I'm not sure there's anything there that hamachi would actually need... – Stephen Kitt Feb 25 '16 at 12:06
  • @StephenKitt Yes, an equivs package would also be a reasonable way to go. Messing around with lsb itself might create problems if other packages depend on a particular version (or version range). – Faheem Mitha Feb 25 '16 at 14:23
  • @StephenKitt, I tried installing the lsb-core package from Jessie, and it had a lot of unsatisfied dependencies as well. I sent an e-mail to the LogMeIn-Hamachi support, and I'll inform when I get an answer from them. Maybe they'll figure out what's the best remedy for this problem. – Jakub Feb 25 '16 at 14:47
0

I contacted LogMeIn and their reply was pretty much that the Hamachi for Linux is a beta and I'm on my own.

I unpacked the .deb package and reviewed the files. I found out that the lsb-core package is needed for installation:

/var/lib/dpkg/info/logmein-hamachi.postinst: 12: /var/lib/dpkg/info/logmein-hamachi.postinst: /usr/lib/lsb/install_initd: not found

and removal:

/var/lib/dpkg/info/logmein-hamachi.prerm: /usr/lib/lsb/remove_initd: not found

of the hamachi client.

I removed the dependency from the control file and the package installed (with the above "not found" errors of course). I had to start the client manually after reboot, but it works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.