0

I need to configure TLS1.1 for lftp?Also how can I check which version of TLS is running on my Redhat Linux OS ?

  • What configuration did you try and what issues did you have? – EightBitTony Feb 24 '16 at 21:27
  • 1
    Please find below the config: /usr/local/bin/lftp -d open -p 20990 -u test,test ftps://ftpssl.google.com set ftp:ssl-allow true set ftp:ssl-force true set ftp:ssl-protect-data true set ftp:ssl-protect-list true debug 13 cd outbound/HV Error when using /usr/local/bin/lftp (openssl library) lftp Iam putting the error logs in pasty: .pastie.org/10736829 – biz Feb 25 '16 at 8:41
0

From the lftp man page, it looks like the lftp setting needed for configuring the TLS protocol version is ssl:priority. Thus you might try the following:

$ /usr/local/bin/lftp -d open -p 20990 -u test,test ftps://ftpssl.google.com 
lftp> set ftp:ssl-allow true
lftp> set ftp:ssl-force true
lftp> set ftp:ssl-protect-data true
lftp> set ftp:ssl-protect-list true
lftp> set ssl:priority NORMAL:+VERS-TLS1.1:+VERS-TLS1.2
lftp> debug 13
lftp> cd outbound/HV

Note the additional setting of ssl:priority; the values depend on whether your lftp was compiled using OpenSSL or GnuTLS. Since your output indicated GnuTLS, the above example shows the GnuTLS priority string value.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.