1

Fresh install Of Mint 17.

I have few partition and 3 OSs Win/Ubuntu-Gnome/ and this newly installed Mint. One of these partition is a storage disk for all documents, photos etc.. and I used to use it from both Linux OSs without any problem and mount it during start by editing fstab. Last days i decided to try Mint 17.3 and after installation I wanted to edit fstab via disk manager and

  • after changing mounting properties to

    dev/disk/by-uuid/xxxx(here proper UUID) /mnt/Local ext4 nosuid,nodev,nofail,x-gvfs-show 0 0
    

    it failed with

    Error mounting system-managed device /dev/sda3:
    Command-line mount "/mnt/Local"' exited with non-zero exit status 32:
    mount: wrong fstype, bad option, bad superblock on /dev/sda3`
    
  • So I check it with fsck.ext4 /dev/sda3 : no faults
  • Then I tried mount with mount /dev/sda3 /mnt/Local And it was mounted successfully :) (and it is mounted as ext4 - as it should be)

I tried all possible options via UUID, via /dev/sda3 via LABEL and it is not working - the same error... I have to add that the same option in fstab under my Ubuntu Gnome works properly... Any ideas?

bumped to the homepage by Community yesterday

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • Did you try mounting with "defaults" instead of "nosuid,nodev,nofail,x-gvfs-show" ? – Dani_l Feb 24 '16 at 17:27
  • yes, i tried, with the same result... – Korbaczek Feb 24 '16 at 17:28
  • when you mount manually, mount | grep sda3 - what's the output? can you try using those exact options in your fstab? – Dani_l Feb 24 '16 at 17:30
  • It looks like something is wrong with x-gvfs-show.. (other options works fine). Don't know why as it used to work always (i used it in many distros) Thanks for all comments guys! i will try to investigate what's wrong with gvfs-show. – Korbaczek Feb 24 '16 at 18:47
0

First Method:

  1. using the following command to check filesystem type and UUID and partition associated

    # sudo blkid
    
  2. in /etc/fstab add the entry in following format as

    UUID=XXX.XXX.XXX /mnt/local   ext4    defaults        0 0
    

    (in-case file system is ext4)

  3. mount the partition using

    # mount -a
    
  4. to check partion is working fine or not using

    # df -h
    

Another method:

  1. use following command to check the partition(current and umounted)

    # lsblk
    
  2. enter the entry in /etc/fstab eg: if block partition is /dev/sda6

    /dev/sda6 /mnt/local ext4 defaults 0 0 
    

Any one method will help you...

  • As i wrote above - it is a problem with x-gvfs-show. Not a matter of fs_spec or fs type (checked with all possible and relevant) or if a partition is working (it is). – Korbaczek Feb 24 '16 at 19:07
  • I will get back on this soon – naveen dharman Feb 24 '16 at 19:09
  • I was going through google and found one link, kindly check with this method by adding comment=x-gvfs-show askubuntu.com/questions/454225/… – naveen dharman Feb 24 '16 at 19:13
  • Yes, found the same... i have to check why it worked on other distros.. (perhaps it was not working and just ignoring this param) Thanks! – Korbaczek Feb 24 '16 at 19:16
  • Looks like it was discussed few times - askubuntu.com/questions/594197/… – Korbaczek Feb 24 '16 at 19:18
0

The problem is with wrong option "x-gvfs-show". "comment=x-gvfs-show" shall be used instead. https://askubuntu.com/questions/594197/unrecognized-mount-option-x-gvfs-show-or-missing-value

0

From your question it seems you wrote /dev/disk/by-uuid/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx /mnt/Local ext4 nosuid,nodev,nofail,x-gvfs-show 0 0 in your /etc/fstab when it should be UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx /mnt/Local ext4 rw,nosuid,nodev,exec,auto,nouser,async,nofail,comment=x-gvfs-show 0 0.

(defaults: rw suid dev exec auto nouser async)

  • Thanks, but you can address it by few things :) I checked them all and it was not a matter here. – Korbaczek Feb 24 '16 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.