3

My computer:

  • Debian 8.3
  • Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17) x86_64 GNU/Linux
  • Dell Latitude 5420

I'm using XMonad window manager, some applets (in stalonetray) from mate desktop (nm-applet, power-manager applet) and i3lock for locking the screen.

Problem:

Usually everything works fine when resuming from sleep/hibernation/suspend, but sometimes after resuming from sleep, I enter the password which unlock the screen (i3lock), desktop content appears and I can move the mouse (both external USB and internal touchpad and trackpoint) - but keyboard (both laptop's builtin and external USB) doesn't work.

When this happens:

  • the keyboard itself works - the CAPSLOCK/NUMLOCK leds reacts to pressing CapsLock or NumLock keys
  • I can switch to console (CTRL-ALT-F1) and keyboard works in console and I can go back to X11 using (ALT-F7)
  • but in X11, nothing reacts to keypresses
  • pulling keyboard's USB connector out and back in doesn't help
  • when I suspend the laptop again (from console) and resume, the mate's screen locker appears but the keyboard still doesn't work.

What I tried:

My only solution is to manually kill mate-session, mate-power-manager or mate-screensaver from console and then the keyboard works in X11 again.

I think that perhaps mate-power-manager tries to lock the screen after I unlock it with i3lock, but somehow doesn't display itself..

The question:

What can I do to prevent mate-* components from locking the screen or blocking the keyboard (assuming I'm correct)?

4
  • 1
    If you take i3lock out of the equation, do you still have this problem? From a text console, run DISPLAY=:0 xinput list, is the output different in normal operation and when you have the problem? Still from a text console, run DISPLAY=:0 xev and switch back to X then type a few keys, does xev report KeyPress events? Commented Feb 24, 2016 at 22:42
  • @Gilles ok, that's a good idea (xev, xinput) - as for i3lock - it's hard to tell, because as I've said in the question - the problem is not 100% reproducible - it happens only sometimes, and I have no idea what triggers it (except for some murphy's law - it often happens when I open the laptop to show something to my superiors :) or generaly when it's most annoying). Anyway - thanks for the comment, it's definitely helpful
    – Jan Spurny
    Commented Feb 25, 2016 at 9:39
  • have you tried this forums.linuxmint.com/viewtopic.php?t=152185 ? Commented Oct 9, 2016 at 8:13
  • @TummalaDhanvi I "solved" (i.e. it hasn't happened again...yet) this by disabling mate-power-manager - which is not the best solution, but I can live without it. I do not think it's a i8042 problem - but if it will happen again, I could try it. Thanks.
    – Jan Spurny
    Commented Oct 9, 2016 at 20:23

1 Answer 1

1

There's a half solution in https://superuser.com/a/1106756/632116

You can try to plug a new USB device on the USB hub where keyboard connected to. That article said do this could make the keyboard works back to normal.

UPDATE 2017-10

This issue had gone after I changed my keyboard to another new one.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .