1

I have LDAP server configured (with YaST) on SLES 11SP4 and I've created 3 users. I can su (from root) to any of the user but I cannot login as any of them or change their passwords.

When I tried to log on (using su as standard user) in /var/log/messages I have:

suse1 su: pam_ldap: error trying to bind as user "uid=user3,dc=linux" (Invalid credentials)
suse1 su: FAILED SU (to user3) root on /dev/pts/0

When I tried change the password in /var/log/messages:

suse1 passwd[5864]: pam_unix2(passwd:chauthtok): user "user1" does not exist in /etc/passwd or NIS
suse1 passwd[5864]: pam_ldap: error trying to bind as user "uid=user1,dc=linux" (Invalid credentials)

My /etc/pam.d/common-password:

password        requisite       pam_pwcheck.so  nullok cracklib 
password        sufficient      pam_unix2.so    use_authtok nullok 
password        required        pam_ldap.so     try_first_pass use_authtok

My /etc/pam.d/common-auth:

auth    required        pam_env.so      
auth    sufficient      pam_unix2.so    
auth    required        pam_ldap.so     use_first_pass

I cannot find out what is wrong and the password I used for sure is correct. Thanks for any hint.

0

On my case if it could help, I forgot to add the ldap module into /etc/nsswitch.conf

# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd:         compat ldap
group:          compat ldap
shadow:         compat ldap
gshadow:        files ldap

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.