2

I'm unable to type the character ' in urxvt. Nothing happens if I press the button to type it.

If I copy something to the clipboard that contains ', and paste it with shift+insert, the text is inserted without the apostrophes.

If I run another application inside the terminal such as cat or vim, it is usually possible to type ' into that application. However there are some applications in which I still can't type ' when I run them, these include sh, bash, and the terminal emulator found inside neovim. Note that zsh does support writing apostrophes.

I also experience this problem inside other emulators than urxvt, such as bash running in emacs, terminator or a simple tty outside the window manager.

Pressing ' twice doesn't do anything either. The keyboard layout is us model pc105 with options bksp:bksp_escape,compose:rctrl,caps:backspace. The window manager is i3, and the distro is arch.

  • I haven't tagged the question urxvt since the problem also happens in other emulators, as mentioned in the end of the question. – Alice Ryhl Feb 24 '16 at 10:14
  • urxvt is a terminal emulator, bash is a shell, emacs is a text editor (officially :) . if you try gnome-terminal or konsole or other terminal emulator, does it work? does it work in console? what DE/WM are you using? – schaiba Feb 24 '16 at 10:22
  • 1
    Does it work if you hit ' twice? What keyboard layout are you using? – terdon Feb 24 '16 at 10:31
  • I have added additional information to the question. – Alice Ryhl Feb 24 '16 at 10:42
  • Does it happen in other shells? On many systems, sh is also bash (just run in POSIX mode). What OS are you using? Do you have any other shells installed to test on? If not, try installing zsh or dash, both of which should be available in your system's repositories. – terdon Feb 24 '16 at 10:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.