2

I am trying to script a Debian installation using virt-install and a preseed.cfg file. I am installing into a virtual machine.

Currently, I am using an ISO file rather than a network installation. I ran into the same problem as another user. That is,

  1. --extra-args can not be passed when using --cdrom
  2. giving the path of the iso as --location doesn't seem to work either.

So I followed the Debian wiki instructions to modify the iso with my preseed.cfg file.

The installation now works entirely automatically, except for one final detail. The ISO I used throws up a splash screen on boot, offering the menu where the options are

  • Live (amd64)
  • Live (amd64 failsafe)
  • Install
  • Graphical Install
  • Advanced Options

Once I select 'Install' the rest works perfectly. However, I would like to skip this screen and install directly, but I can't figure out how to do so. Does it require adding an option to the debian preseed.cfg file, modifying the iso, or adding another parameter to virt-install? (Bear in mind the --extra-args constraint).

2

As you're remastering the ISO anyway, you can set a timeout in the isolinux/isolinux.cfg file. Prepend

TIMEOUT 1

and be patient for 0.1 s during boot. You could also start your desired kernel with custom arguments and skip the boot menu completely, but the above is the simplest solution if the default fits you.

  • Thank you, this was the clue I needed. I also removed live.cfg from the menu options. so that Install became the topmost default after the timeout expires. In particular, sed -i "s/timeout 0/timeout 1/" isolinux/isolinux.cfg && sed -i "s/include live.cfg/#include live.cfg/" isolinux/menu.cfg. I have accepted the answer as it stands. – SauceCode Feb 25 '16 at 0:38
  • 1
    Ah, so it had a TIMEOUT directive already. Glad you solved it! You could have added a DEFAULT directive instead of removing the first item, but the lost functionality probably does not matter to you now. – Ferenc Wágner Feb 25 '16 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.