0

I have two Audio CDs to prepare for my upcoming English test. I can play the first CD by execute vlc cdda:// in konsole (I use Arch Linux with KDE). I also note that the Audio CD appears in the Devices panel in Dolphin. Unfortunately, for the second CD, nothing appears in Dolphin and I also can't play this CD with vlc.

I run cd-info /dev/cdrom with the the second CD inside and get

cd-info version 0.93 x86_64-unknown-linux-gnu
Copyright (c) 2003-2005, 2007-2008, 2011-2013 R. Bernstein
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.
CD location   : /dev/cdrom
CD driver name: GNU/Linux
   access mode: IOCTL

Vendor                      : Slimtype
Model                       : DVD A  DS8A5SH  
Revision                    : XAA2
Hardware                                  : CD-ROM or DVD
Can eject                                 : Yes
Can close tray                            : Yes
Can disable manual eject                  : Yes
Can select juke-box disc                  : No

Can set drive speed                       : No
Can read multiple sessions (e.g. PhotoCD) : Yes
Can hard reset device                     : Yes

Reading....
  Can read Mode 2 Form 1                  : Yes
  Can read Mode 2 Form 2                  : Yes
  Can read (S)VCD (i.e. Mode 2 Form 1/2)  : Yes
  Can read C2 Errors                      : Yes
  Can read IRSC                           : Yes
  Can read Media Channel Number (or UPC)  : Yes
  Can play audio                          : Yes
  Can read CD-DA                          : Yes
  Can read CD-R                           : Yes
  Can read CD-RW                          : Yes
  Can read DVD-ROM                        : Yes

Writing....
  Can write CD-RW                         : Yes
  Can write DVD-R                         : Yes
  Can write DVD-RAM                       : Yes
  Can write DVD-RW                        : No
  Can write DVD+RW                        : No
__________________________________

Disc mode is listed as: Error in getting information
++ WARN: error in ioctl CDROMREADTOCHDR: No medium found

cd-info: Can't get first track number. I give up.

I installed libdvdread, libdvdcss, libdvdnav and tried with vlc dvd:///dev/sr0 but konsole returned errors. Can anyone help me to play the CD?

  • Is it possible that the 2nd CD is physically bad or perhaps written at a speed too high? – schaiba Feb 23 '16 at 18:53
  • You may try with another program. For example mpv cdda:// – Francesco Turco Feb 23 '16 at 21:29
  • @schaiba The 2nd CD plays well with Windows Media Player on Windows, so I don't think that CD is damaged. – macnguyen Feb 24 '16 at 1:29
  • As @Francesco Turco suggest, I installed mpv and now I can play that CD. But I am still curious why mpv can play, but vlc can't? – macnguyen Feb 24 '16 at 1:58
  • 2
    @macnguyen: I don't know why mpv works and vlc doesn't, but I have a suggestion for you: why don't you try to rip the CD to the hard disk with a tool such as cdparanoia? Rip once and then forget about it. Also libdvdread, libdvdcss and libdvdnav are tools for watching/ripping video DVDs, not audio CDs. – Francesco Turco Feb 24 '16 at 12:55
1

Well, here's your error:

++ WARN: error in ioctl CDROMREADTOCHDR: No medium found

It seems your medium is either non-redbook compliant, is faulty or damaged, or your drive is faulty (seems less likely considering the other CD works).

If your CD works on another audio player, it may be that it contains Digital Restrictions Management technology, which you don't have the required technology to interact with.

  • I can open audio files of the 2nd CD on my friend's computer (which is running Windows), but only by Windows Media Player. VLC can't open the files in that CD. I also test with a Linux Mint Live USB, but VLC on the LiveUSB can not play the CD, too. So is it restricted by DRM? – macnguyen Feb 24 '16 at 1:26
  • "Audio files"? If this is a CDDA disk then there shouldn't be "audio files", unless your OS is abstracting them. Are you sure this is CDDA at all? – Chris Down Feb 24 '16 at 15:35
  • I may be misunderstand, but when I put the CD into my laptop, a tab 'Audio CD' appears in Devices panel in Dolphin. So I think it's audio files. Is it right? – macnguyen Feb 26 '16 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.