1

Trying to use ndiswrapper on Arch, I got the following error (that is actually the result of the command: ndiswrapper -l):

modinfo: ERROR: Module ndiswrapper not found.
module version is too old!
utils version: '1.9', utils version needed by module: '0'
module details:
modinfo: ERROR: Module ndiswrapper not found.

You may need to upgrade driver and/or utils to latest versions available at
http://ndiswrapper.sourceforge.net

However, I installed ndiswrapper-dkms from the community repository. How can I solve that? I am running on kernel 4.4.1-2.

EDIT: I tried to compiled ndiswrapper from sources, too, but without success. The error I get is the following:

ndiswrapper-1.59/driver/crt.c:470:2: error: implicit declaration of 
function ‘net_srandom’ [-Werror=implicit-function-declaration]

net_srandom(seed);
^
  • Please edit your question and explain how compiling from source failed. If the version in AUR is too old, that might be your only choice. – terdon Feb 23 '16 at 17:44
1

You need to apply this pach: ndiswrapper-patched-3.14

Run the following command :

git clone https://github.com/Schwartz/ndiswrapper-patched-3.14.git
cd ndiswrapper-patched-3.14
make
  • I still have errors (see here): implicit declaration of function '__vmalloc', 'vmalloc' and 'vfree'... =/ – JonasVautherin Mar 14 '16 at 14:46
  • Sorry, but I don't get your point. Do you mean that I should follow the "INSTALL" instructions? I still get the same compilation errors... – JonasVautherin Mar 15 '16 at 7:16
  • Adding #include <linux/vmalloc.h> to "driver/loader.c" moves to another issue: "implicit declaration of function 'strnicmp'". – JonasVautherin Mar 15 '16 at 8:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.