1

I've installed both Debian 8 and Windows 7 on my pc. The thing is, Debian audio drivers produce really choppy sounds. Windows works fine.

After trying some methods from google, I actually feel more frustrated. None of them works, like this article mentions.

I'm not sure which sorts of information I need to provide so please feel free to ask me for any required information. I really appreciate your help.

Edit

Audio card info:

00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)

I've tested with mp3 files and youtube videos running on Chrome HTML5 player, Debian built-in Videos player and vlc media player. They produce the sounds that's similar to listening to music online with 1KB/s network speed.

  • What hardware do you use? What media applications? What have you tried? – schaiba Feb 23 '16 at 9:24
  • 1
    @schaiba What hardware do you use? Not sure which kinds of hardware are you asking for? Audio cards? Please give me the exact command for retrieving the info. What media aplications? Both built-in Debian media application and Chrome's media applications (HTML5 + flash). What have you tried? 5 methods listed in the link. – Lewis Feb 23 '16 at 9:42
  • Clearly, more information is needed like what do you mean by choppy, what audio-card/s, Mobo, which media-players, etc. – We are Borg Feb 23 '16 at 10:30
  • 1
    Can you try this command : pulseaudio -k && sudo alsa force-reload . This will kill your pulse-audio and reload alsa. – We are Borg Feb 23 '16 at 16:23
  • 1
    @WeareBorg No, I haven't touched any alsa packages. I think Debian 8 doesn't have this command by default. Do you mean the command alsactl instead? – Lewis Feb 23 '16 at 16:29
4

Please provide more information about your hardware:

If we are talking built-in audio:

lspci | grep -i audio

If you are using a USB sound card:

lsusb

If this is a laptop or a brand desktop, the model will help as well. If you built your own PC, what is the motherboard or sound card you use.

also, ensure the mixer is not muted, issue alsamixer ... ensure you have the correct card, as printed at the top, if not, in alsamixer, hit F6.

I hope this helps.

Update, op has provided details. This looks like what is described in the Arch wiki:

Glitches, skips or crackling

The newer implementation of the PulseAudio sound server uses timer-based audio scheduling instead of the traditional, interrupt-driven approach.

Timer-based scheduling may expose issues in some ALSA drivers. On the other hand, other drivers might be glitchy without it on, so check to see what works on your system.

To turn timer-based scheduling off add tsched=0 in /etc/pulse/default.pa:

load-module module-udev-detect tsched=0

Then restart the PulseAudio server:

$ pulseaudio -k
$ pulseaudio --start

Do the reverse to enable timer-based scheduling, if not already enabled by default.

If you are using Intel's IOMMU and experience glitches and/or skips, add intel_iommu=igfx_off to your kernel command line.

Some Intel audio cards using the snd-hda-intel module need the otions vid=8086 pid=8ca0 snoop=0. In order to set them permanently, create/modify the /etc/modprobe.d/sound.conf including the line below.

options snd-hda-intel vid=8086 pid=8ca0 snoop=0
  • 2
    This should be a comment, not an answer. – RealSkeptic Feb 23 '16 at 9:59
  • 1
    True, but comments are restrained, character-count-wise. – thecarpy Feb 23 '16 at 10:11
  • Sorry for the late reply. I've updated my question with the info produced from your suggested command. – Lewis Feb 23 '16 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.