-1

I am trying to set up webdav to the /var/www directory on debian 8.4

I can setup webdav to access a subdirectory of /var/www such as /var/www/webdav but when I remove the directive from the apache conf file it doesn't seem to work. for example:

    Alias /webdav /var/www/webdav

    <Directory /var/www/webdav>
        DAV On
    </Directory>

if this is

    Alias /webdav /var/www

    <Directory /var/www>
        DAV On
    </Directory>

I get an error:

cadaver http://192.168.200.85/webdav
Could not access /webdav/ (not WebDAV-enabled?):
Did not find a collection resource.
Connection to `192.168.200.85' closed.

I feel like I'm missing something obvious.

3
  • Please check your /var/log/apache2/error.log file (or the one corresponding to the virtual host in question). – Ferenc Wágner Feb 23 '16 at 10:19
  • There's probably a <directory /var/www> somewhere else in your config file (since it's the root) which doesn't include the DAV on directive. You should modify that one, not add another one. – EightBitTony Feb 23 '16 at 12:31
  • even when adding "DAV On" to the <directory /var/www> i still get: root@computer:/# cadaver 192.168.200.85 Could not access / (not WebDAV-enabled?): 405 Method Not Allowed Connection to `192.168.200.85' closed. – Mike Feb 24 '16 at 5:36
-1

To solve this issue, I setup a symlink for the folder that is accessed via webdav.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.