1

I'm setting up rtpproxy on a debian 8.3 server through the default package available in the repos. The package comes with the sysvinit script still, and I want to use a keepalive so I'm trying to set up a systemd service file. I'm borrowing from their github repo a bit from what seems like their Fedora setup. I also chose to forego their socket/service type setup in favor of the more traditional rtpproxy method of defining the socket in the Exec command. Here's what I'm using:

[Unit]
Description=A symmetric RTP proxy
After=network.target

[Service]
Type=forking
User=rtpproxy
Group=rtpproxy
EnvironmentFile=/etc/default/rtpproxy
PIDFile=/var/run/rtpproxy/rtpproxy.pid
ExecStart=/usr/bin/rtpproxy -s $CONTROL_SOCK -p /var/run/rtpproxy/rtpproxy.pid $EXTRA_OPTS
Restart=always
TimeoutStopSec=30s

[Install]
WantedBy=multi-user.target

Variables $CONTROL_SOCK and $EXTRA_OPTS are defined in /etc/default/rtpproxy.

While this does work, it takes a while for the process to finish starting up only if the system has been rebooted (it seems). If it's been running and I restart the process, it's quick. How can I determine why this process is taking so long to start up on system boot?

1 Answer 1

0

Add a suitable -d option to tune up the debug level, and then you'll see in the logs which step takes long.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .