Is there any way to disable the animation which occurs when attempting to unlock gnome Screensaver and failing? Currently the password dialog shakes back and forth and for some reason on some laptops, this animation causes the entire system to be unresponsive for about 5 - 7 seconds. Can be very frustrating because it increases the chances of a second, third, etc mistyped passsword.

I'm currently on Fedora 11 but this issue also occurs in Ubuntu. The Ubuntu change log calls this feature "Shake the dialog when authentication fails"

gnome-screensaver (0.0.17-0ubuntu1) dapper; urgency=low

  * New upstream release:
    - 0.0.16:
      - Shake the dialog when authentication fails

 -- Daniel Holbach <daniel.holbach@ubuntu.com>  Mon, 24 Oct 2005 21:14:22 +0200
  • My initial inclination was to post this on SuperUser.com but I figured I'd let the new kids on the block try first ;-) – Josh Oct 3 '10 at 0:03

For a moment, I thought that this might be inherited from the GDM configuration (since the GDM login screen does the same thing), but apparently it's not.

After checking a few other places without any luck, I decided to find out for myself and took a look at the source code(v2.30). The code responsible for the shaking only checks to make sure the dialog isn't already being shaken. It makes no checks against any configuration, so there doesn't appear to be a way to disable it without changing the code itself.

You might try switching to xscreensaver and see if that helps.

| improve this answer | |
  • Sorry for the delayed accept @Bill! I was waiting until I could download the source and try commenting this out on my own, but that was a decision I made in a moment of insanity -- I'm never going to find time to do that! :-( – Josh Nov 5 '10 at 14:31
  • could you please point to part of the sourcecode you looked at? I try to find out a way to remove the delay after the shaking: askubuntu.com/posts/comments/2113804?noredirect=1 – rubo77 Jun 20 at 2:48
  • @rubo77 In 2.30 it was there was a shake_dialog function in gs-window-x11.c. That said, I haven't looked at the latest code, but I assume it's similar. – Bill B Aug 7 at 17:20
  • Thanks, it was a bug in the end, that was fixed some days later – rubo77 Aug 8 at 5:00

I just wanted to add that I have found a semi-convenient workaround: if the box begins shaking, you can actually click the "Cancel" button and it will stop the shaking and return to the screensaver -- not instantly, but it is much faster to do that (at least on my machine) than to wait for the shaking to finish. I swear that trying to retype my password when the box is shaking leads to dropped chars and thus fails a second time.

Clicking "Cancel" and then re-opening the password box is what I've been doing ever since!

| improve this answer | |
  • Isn't it hard to click the cancel button if the dialog is shaking? – SamB Jan 13 '11 at 20:37
  • @SamB: The dialog shakes slowly and by less than half the width of the cancel button, so no, if I aim for the middle it's easy. – Josh Jan 13 '11 at 20:47
  • There is no cancel button in the Ubuntu login screen, but I found out, that you can use the mouse to click into the field and you can type immmediately while the box is shaking – rubo77 Jun 20 at 2:52

In gdm3 (tested in Ubuntu 20.04) you can now disable the shaking with

gsettings set org.gnome.desktop.interface enable-animations false

see https://askubuntu.com/a/1252096/34298

If you are only worried about the delay after the shake, that delay is gone in the latest update of yaru-theme-gnome-shell 20.04.7


I think on Ubuntu 20.01 you could edit the theme like described here: https://askubuntu.com/a/654819/34298

gresource extract /usr/lib/gnome-shell/libgnome-shell.so /org/gnome/shell/ui/components/polkitAgent.js
gresource extract /usr/lib/gnome-shell/libgnome-shell.so /org/gnome/shell/gdm/authPrompt.js 

comment out all lines containing the shake command:

// Util.wiggle(this._passwordEntry);

and create a new theme from it and select that one.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.