0

I'm on an archlinux 4.4.1-2 and I'm trying to set up a netctl service. Problem is that for netctl to work I need to have bcma and b43 loaded. Since these two are not out-of-tree modules I thought I didn't had to load them myself.

Neverthless I also tried to load described in this article here. Unfortunalty this doesn't seem to work either. Has anyone an Idea what the problem could be? thanks:D

modinfo of bcma

filename:       /lib/modules/4.4.1-2-ARCH/kernel/drivers/bcma/bcma.ko.gz
license:        GPL
description:    Broadcom's specific AMBA driver
alias:          pci:v000014E4d0000A8DCsv*sd*bc*sc*i*
alias:          pci:v000014E4d0000A8DBsv*sd*bc*sc*i*
alias:          pci:v000014E4d00004727sv*sd*bc*sc*i*
alias:          pci:v000014E4d000043B1sv*sd*bc*sc*i*
alias:          pci:v000014E4d000043AAsv*sd*bc*sc*i*
alias:          pci:v000014E4d000043A9sv*sd*bc*sc*i*
alias:          pci:v000014E4d000043A0sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004365sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004360sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004359sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004358sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004357sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004353sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004331sv*sd*bc*sc*i*
alias:          pci:v000014E4d0000A8D8sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004313sv*sd*bc*sc*i*
alias:          pci:v000014E4d00000576sv*sd*bc*sc*i*

and modinfo of b43

filename:       /lib/modules/4.4.1-2-ARCH/kernel/drivers/net/wireless/b43/b43.ko.gz
firmware:       b43/ucode9.fw
firmware:       b43/ucode5.fw
firmware:       b43/ucode16_mimo.fw
firmware:       b43/ucode15.fw
firmware:       b43/ucode14.fw
firmware:       b43/ucode13.fw
firmware:       b43/ucode11.fw
license:        GPL
author:         Rafał Miłecki
author:         Gábor Stefanik
author:         Michael Buesch
author:         Stefano Brivio
author:         Martin Langer
description:    Broadcom B43 wireless driver
alias:          ssb:v4243id0812rev10*
alias:          ssb:v4243id0812rev0F*
alias:          ssb:v4243id0812rev0D*
alias:          ssb:v4243id0812rev0C*
alias:          ssb:v4243id0812rev0B*
alias:          ssb:v4243id0812rev0A*
alias:          ssb:v4243id0812rev09*
alias:          ssb:v4243id0812rev07*
alias:          ssb:v4243id0812rev06*
alias:          ssb:v4243id0812rev05*
alias:          bcma:m04BFid0812rev2Acl*
alias:          bcma:m04BFid0812rev28cl*
alias:          bcma:m04BFid0812rev1Ecl*
alias:          bcma:m04BFid0812rev1Dcl*
alias:          bcma:m04BFid0812rev1Ccl*
alias:          bcma:m04BFid0812rev18cl*
alias:          bcma:m04BFid0812rev17cl*
alias:          bcma:m04BFid0812rev15cl*
alias:          bcma:m04BFid0812rev11cl*
depends:        mac80211,ssb,bcma,led-class,mmc_core,cfg80211,rng-core
intree:         Y
vermagic:       4.4.1-2-ARCH SMP preempt mod_unload modversions 
parm:           bad_frames_preempt:enable(1) / disable(0) Bad Frames Preemption (int)
parm:           fwpostfix:Postfix for the .fw files to load. (string)
parm:           hwpctl:Enable hardware-side power control (default off) (int)
parm:           nohwcrypt:Disable hardware encryption. (int)
parm:           hwtkip:Enable hardware tkip. (int)
parm:           qos:Enable QOS support (default on) (int)
parm:           btcoex:Enable Bluetooth coexistence (default on) (int)
parm:           verbose:Log message verbosity: 0=error, 1=warn, 2=info(default), 3=debug (int)
parm:           pio:Use PIO accesses by default: 0=DMA, 1=PIO (int)
parm:           allhwsupport:Enable support for all hardware (even it if overlaps with the brcmsmac driver) (int)
  • Can you go into a bit more detail on how it didn't work? What did you see, what did you expect to see? – Wouter Verhelst Feb 21 '16 at 21:16
  • I am expecting to have bcma and b43 in lsmod after boot. But i have to modprobe them myself. So actually without these two modules my wireless card isn't detected and my wlan0 interface is missing – bmblby Feb 22 '16 at 22:11
1

There is a file /etc/modules which lists modules to be loaded at boot. Just add those modules to that file

  • 1
    Thank you this helped me a little. Because I am on Arch Linux there is no modules file in /etc/, but there is another location where modules are configurated on arch. It is in /usr/lib/ and exactly there, my modules where blacklisted. So I removed a file in /usr/lib/modprobe.d that blacklisted the modules and know it works. – bmblby Mar 19 '16 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.