1

I rebooted my vServer (Debian 8) and it doesn't came back up. Well, I used the rescue console on my server and the server seems to be running fine, except the network was broken. So I tried 'ifconfig' but nothing came up. So I tried to enable my interface with 'ip link set dev venet0 up' and 'ifup venet0:0' and now it appears in my ifconfig list:

root@i67svof:/# ifconfig
venet0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
          RX packets:65 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:5008 (4.8 KiB)  TX bytes:0 (0.0 B)

venet0:0  Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:MYIPV4ADDR  P-t-P:addr:MYIPV4ADDR  Bcast:addr:MYIPV4ADDR  Mask:255.255.255.255
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1

My HWaddr doesn't look that well :) 'ip addr' prints this result:

root@i67svof:/# ip addr
1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: venet0: <BROADCAST,POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN 
    link/void 
    inet MYIPV4ADDR/32 brd MYIPV4ADDR scope global venet0:0

These are the last lines in /var/log/syslog:

root@i67svof:/var/www# tail /var/log/syslog
Feb 20 11:34:16 i67svof systemd[1]: Stopping memcached daemon...
Feb 20 11:34:16 i67svof systemd[1]: Stopping Network Name Resolution...
Feb 20 11:34:16 i67svof systemd[1]: Stopping Regular background program processing daemon...
Feb 20 11:34:16 i67svof systemd[1]: Stopping Login Prompts.
Feb 20 11:34:16 i67svof systemd[1]: Stopped target Login Prompts.
Feb 20 11:34:16 i67svof rsyslogd: [origin software="rsyslogd" swVersion="8.4.2" x-pid="22100" x-info="http://www.rsyslog.com"] exiting on signal 15.
Feb 20 12:17:12 i67svof rsyslogd: [origin software="rsyslogd" swVersion="8.4.2" x-pid="129" x-info="http://www.rsyslog.com"] start
Feb 20 12:17:32 i67svof postmulti[222]: warning: /etc/postfix/main.cf, line 18: overriding earlier entry: myorigin=/etc/mailname
Feb 20 12:17:32 i67svof postmulti[222]: fatal: could not find any active network interfaces
Feb 20 12:17:34 i67svof rsyslogd: [origin software="rsyslogd" swVersion="8.4.2" x-pid="129" x-info="http://www.rsyslog.com"] exiting on signal 15.

And finally my network config in /etc/network/interfaces

# Auto generated lo interface
auto lo
iface lo inet loopback

# Auto generated venet0 interface
auto venet0
iface venet0 inet manual
        up ifconfig venet0 up
        up ifconfig venet0 127.0.0.2
        up route add default dev venet0
        down route del default dev venet0
        down ifconfig venet0 down


iface venet0 inet6 manual
        up ifconfig venet0 add MYIPV6ADDR/64
        down ifconfig venet0 del MYIPV6ADDR/64
        up route -A inet6 add default dev venet0
        down route -A inet6 del default dev venet0

auto venet0:0
iface venet0:0 inet static
        address MYIPV4ADDR
        netmask 255.255.255.255

Can anyone help me with this one? Thanks in advance!

0

Try to set network interfaces down before setting them up. For example, in AlpineLinux it can be done by adding these lines to /etc/init.d/networking:

for iface in $(find_ifaces); do
    ifdown $iface > /dev/null 2>&1
done

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.