I have the no-ip service running on my raspberry pi, it updates the DNS (no-ip) whenever there is a change to it's IP address. I have enabled port forwarding on my router (Asus rt-n66u) ports 22 & 80, pointing to the intranet IP of the pi. I have not adjusted any firewall settings, everything about the router is 'out of the box' including firmware.

When I ping the domain name, I get 0 packet loss.

When I try to connect via ssh:

OpenSSH_6.9p1, LibreSSL 2.1.7
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 20: Applying options for *
debug1: /etc/ssh/ssh_config line 102: Applying options for *
debug1: Connecting to [DOMAIN_NAME] [MY_GlOBAL_IP] port 22.
debug1: connect to address [MY_GlOBAL_IP] port 22: Operation timed out
ssh: connect to host [DOMAIN_NAME] port 22: Operation timed out

Is there something that I need to check with my router configuration and network setup perhaps?

Also note, I am able to connect via the local IP address of the intranet, i.e. 192.168.1.231 ssh just fine.

  • 2
    Unless your pi is missing a default route or something like that, this sounds like a question about your router's NAT and firewall, not about the pi. On topic if that router/firewall is Unix-based (but then you need details on its configuration), off topic if not. – Celada Feb 20 '16 at 22:12
  • 1
    Where are you connecting from? Is the Pi running any firewall (iptables -L?) As well as enabling port forwarding on your router, have you change the router to allow incoming ssh traffic (it's usually a two step process). You may be better served asking this over at SuperUser, but it does depend on where the problem lies. – EightBitTony Feb 20 '16 at 22:19
  • I am connecting from my LAN the same one the Pi is on. I upgrades the firmware to Asuswrt-Merlin and enabled ssh on port 22 in the admin settings. – Andy Coles Feb 20 '16 at 23:40
  • arget prot opt source destination fail2ban-ssh tcp -- anywhere anywhere multiport dports ssh – Andy Coles Feb 20 '16 at 23:43
  • install tcpdump on pi and run this: tcpdump -nni any tcp port 22 as root and try connecting. If there are no new lines showing attempts, then problem is in your router setup. – user140866 Feb 22 '16 at 4:18

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.