I just installed the nvidia drivers on fedora 23 (kernels 4.2.3 and 4.3.5), and it worked fine for 1 or 2 restarts, but during my last few reboots, cinnamon has crashed and started in fallback mode (fedora 23 with cinnamon) and upon further investigation I saw that it was loading the nouveau driver.

Not sure why nouveau driver would cause cinnamon to go into fallback mode (or if that's happening for an altogether different reason)

So I tried forcing X to use the nvidia driver.

Section "Device"
    Identifier  "GTX 550-Ti"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"
    BusID       "PCI:1:0:0"

What happens when I boot with these X options, is a "unable to handle kernel paging request" bug, (kernel seems to crash but doesn't say kernel panic; I'd share the message but don't know how) and I'm all out of ideas. The drivers seem like they're working outside of X though, and the kernel paging bug doesn't occur until X is started.

To confirm that my system is working on nouveau, uninstalling nouveau fixes cinnamon's crashing error. I guess what's happening is cinnamon trying to load Nvidia drivers, crashes, and goes to fallback mode on nouveau drivers where it doesn't crash. Xorg.Log didn't seem to provide any useful insights (it didn't throw any errors, just tried to load Nvidia driver and then all of a sudden switches to loading nouvau instead; it doesn't seem to successfully load any of the nvidia driver)


Strange enough reinstalling the complete driver fixed this. (I had tried reinstalling the kernel module part of it many times)

To fix run this (Assuming you use DNF package manager):

dnf remove xorg-x11-drv-nvidia xorg-x11-drv-nvidia-libs akmod-nvidia kmod-nvidia* && dnf install akmod-nvidia kmod-nvidia

I traced the cause of the issue back to regenerating the UEFI grub config file and restarting.

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg 

I was trying to apply a grub theme (it failed for some reason); any extra attempts to do so (with or without changes to /etc/default/grub) will make the problem recur. The problem is reproducible, here is what I did to /etc/default/grub:

echo "GRUB_THEME=\"/boot/grub2/themes/system/theme.txt\"" >> /etc/default/grub

Then regenerated the config file (using the formerly mentioned mkconfig command) and rebooted. I'm not sure if the GRUB_THEME line I added is needed to make this bug occur, it seems to be being ignored, and furthermore after the reboot a new line is added to /etc/default/grub (GRUB_GFXPAYLOAD_LINUX=text)

I will report this as a bug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.