1

Just installed Ubuntu 14.04 on my Macbook Pro Retina from the great tutorial over at MakeUseOf, and have been enjoying the new OS with the exception of the trackpad performance.

To be able to customize the trackpad options, primarly to ignore my thumb (like it does in OS X), I've been trying to install Mtrack, but it doesn't seem to work:

sudo apt-get install xserver-xorg-input-mtrack

Is met with these errors:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-input-mtrack : Depends: xorg-input-abi-20
                             Depends: xserver-xorg-core (>= 2:1.14.99.902)
E: Unable to correct problems, you have held broken packages.

And when I try to deal with those dependencies, I get more errors.

Also, I just tried installing via aptitude and since running that install I can't boot back into Ubuntu anymore...

I've also tried installing it via this guy's method, which compiles the Mtrack program from its Github page. It seems to work ok, but then when I get to creating the necessary xorg.conf file and restart, my cursor disappears.

I've also tried playing around with the synaptics file in usr, but the "ignore thumb = true" option that Mtrack uses doesn't work there...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.