1

I just created a new ext4 filesystem on a new drive and I am trying to mount it manually:

mount /dev/sdc1 a

it does mount correctly, but then only root seems to have write permissions. How can I give write permissions to my user as well?

  • Is this a permanent thing? If so, you can add the drive to your /etc/fstab with the user option activated. – Fiximan Feb 19 '16 at 21:50
2

This is normal behavior - mount doesn't give write permissions at all. The write permissions are controlled by the permissions bits on the directory in the filesystem (i.e. after it's mounted). To manage who can read and write from/to this filesystem, just use the normal chown and chmod tools.

  • Why does mount change the ownership of the directory? Initially this a directory was owned by my user with write permission on it. – Grzenio Feb 19 '16 at 20:12
  • 2
    @Grzenio mount temporarily overlays the directory a with the / directory of the filesystem that has been mounted. a's owner, its permissions, even all of its contents, are all hidden. When you unmount the filesystem, you can access a just as it was before. – Mark Plotnick Feb 19 '16 at 20:25
  • The directory a prior to the mount is a completely different item than the filesystem at a after the mount. – John Feb 19 '16 at 23:58
  • "mount doesn't give write permissions at all." For the sake of completeness, some filesystems (the ones which don't support Unix permissions, e. g. fat and vfat) may be provided uid, gid and some ?mask options through mount to control access. – Murphy Feb 20 '16 at 16:46
0

As Mark Plotnick said, mount just overlays a directory in your system with the contents of / on the attached drive.

To circumnavigate this and as an expansion to John's answer, you can try

chmod -R -rwxrw-rw a

or

chmod -R 755 a

depending on your preference. The command will change all files in a to give you RW permissions.

Alternatively, if ls -l reports that root is the owner:

chown -R <your name here> a

would make you the owner of all the files in a.

chmod and chown with -R can mess up some intentional permissions modifications on files, so do exercise caution when executing such commands.

  • 1
    Shouldn't that be chmod -R -rwxrw-rw- a? (with a final - to say unprivileged users can't execute the file.) – David Knipe Sep 24 '18 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.