I am trying to find the correct syntax for mounting a file share of nfs. On the host I have the /etc/export file set like so: /mnt/externalHD,sync) and the client fstab like so: /home/Plex nfs auto 0 0
I have also installed nfs-common and nfs-kernel-server but have had no luck.


In the /etc/fstab file you are missing a ":", it should be: /home/Plex nfs ro,sync 0 0

19.2.1. Mounting NFS File Systems using /etc/fstab

The file is also /etc/exports and not /etc/export. You should start/restart the nfs service after changing /etc/exports.

I will also leave the link about the exports file:

21.7. The /etc/exports Configuration File

As for the actual mount point in the client, it has to exist. Do:

sudo mkdir -p /home/Plex
  • That didn't work. It's not mounted on the client – eekfonky Feb 19 '16 at 21:56
  • I have changed the fstab line – Rui F Ribeiro Feb 20 '16 at 2:34
  • I get this message: mount.nfs: mount point /home/Plex does not exist – eekfonky Feb 20 '16 at 7:59
  • It is a good sign. do a sudo mkdir -p /home/Plex and then sudo mount -a – Rui F Ribeiro Feb 20 '16 at 8:14
  • 1
    have you installed the nfs client? – Rui F Ribeiro Feb 20 '16 at 8:22

I had to sudo systemctl enable rpcbind then do a sudo mount -a this solved it

  • Do you solved your problem? – GAD3R Feb 20 '16 at 9:19
  • I cannot vote for my own post – eekfonky Feb 20 '16 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.