4

My computer doesn't power off when I try to shutdown or reboot it, I'm forced to press the power button.

At shutdown, a single _ is displayed (sometimes blinking, sometimes not).

At reboot, two similar lines are displayed, which say watchdog watchdog0: watchdog did not stop!. These two lines remain for around 0.25 seconds, then the screen turns off but not the computer itself (there's still the "powered on" light).

When the commands are done while in desktop, it may happen that the screen freezes on the tty1 (with the ouput of X server and so), thus none of the cases above happens. I assume it isn't worth anything, but for the sake of precision, you know.

The reboot case may happen at shutdown (and the other way around), I didn't test it so I can't say for sure.

Commands tried:

sudo shutdown -h 0
sudo shutdown -P 0
sudo shutdown now
sudo reboot
sudo systemctl poweroff
sudo systemctl reboot
  • Computer: Asus E403SA-WX0004T
  • Proc: Intel Celeron N3050
  • Kernel: 4.4.1-2-ARCH

I installed Arch from scratch (standard way, I mean I haven't installed a custom distribution based on it or executed Architect), so it may be a module I'm missing. At least I hope it is this simple.

Don't hesitate to ask questions about relevant things I should include.

closed as off-topic by Jeff Schaller, Timothy Martin, Isaac, Kiwy, Christopher Apr 11 '18 at 14:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Timothy Martin, Isaac, Kiwy, Christopher
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I already tried, not for much long though (like 2mins), but at the time of writing this comment the screen is turned off while the computer itself is still powered on. It's been around 6mins now. – Razakhel Feb 18 '16 at 22:24
  • Does nobody have a solution? – Razakhel Mar 4 '16 at 12:14
  • I don't know man, after the last upgrade I get this a lot more often but as I said, it powers off eventually - sometimes it may take even 5 minutes... Have you tried using the SysRq keys when this happens ? – don_crissti Mar 4 '16 at 12:38
  • I never knew about this, thanks for the tip. It works perfectly fine, but forcing all the processes to close is probably a bad way to shutdown I guess. – Razakhel Mar 8 '16 at 19:37
  • Did you manage to resolve this at all? I'm having a similar issue on an Asus Eee PC 1201HA. – Audite Marlow Jun 3 '16 at 15:58
2

Resolved after a Linux upgrade. Not that helpful to understand why though.

1

Several things you can try out.

First have a look through the BIOS and see if any power settings seem off.

Second edit /etc/default/grub and change the line GRUB_COMMAND_LINE_DEFAULT="quiet" to GRUB_COMMAND_LINE_DEFAULT="quiet acpi=force", run grub-mkconfig -o /boot/grub/grub.cfg afterwards and then reboot.

As for the watchdog, check if you have a file called /dev/watchdog, if not then that explains that issue but not the poweroff. Usually watchdog is not used unless you have an embedded device. Watchdog is a process or hardware that checks if the system is still responsive and if not then restarts it. In /etc/systemd/system.conf you can see a line that says #ShutdownWatchdogSec=10min. This is a default setting. All it means is that the system shut down before the 10 min period ran out and systemd did not shut down watchdog. Should not affect the power issue. Though one never knows.

  • I assume there is no problem with the BIOS whatsoever, since I've been using elementaryOS for about 4 months without an issue. Though it's worth taking a look if necessary. About the Watchdog, the line is indeed commented, but the one above, #RuntimeWatchdogSec=0 is as well. Doesn't it mean that the watchdog shouldn't start anyway? Or its start is mandatory whatsoever? I'm going to try your grub solution. – Razakhel Feb 19 '16 at 1:36
  • Forcing the ACPI does not work, unfortunately. – Razakhel Feb 19 '16 at 1:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.